[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [prov] Version defaults for root IU

I ran the metadata generator twice against the sdk and changed the rootVersion for the second run. I didn't check the result for correctness but it worked when each version was specified.

Inactive hide details for Pascal Rapicault <Pascal_Rapicault@xxxxxxxxxx>Pascal Rapicault <Pascal_Rapicault@xxxxxxxxxx>


          Pascal Rapicault <Pascal_Rapicault@xxxxxxxxxx>
          Sent by: equinox-dev-bounces@xxxxxxxxxxx

          12/03/2007 08:39 PM

          Please respond to
          Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

To

Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

cc


Subject

Re: [equinox-dev] [prov] Version defaults for root IU

It is possible and will be in 1.0. We have been using this functionality to
test M3 by having a repository containing the I-builds of the SDK
(
http://download.eclipse.org/eclipse/testUpdates/, note that the refered
site currently only contains one version of the SDK because it is being
purged every week. It will contain multiple version next week when I builds
are being run every 4 hours).

The problem you are encountering is likely caused by limitations in our
resolver. It will be addressed in M5.

For context, do you have anything else in your repository? How / from what
did you generate the metadata?

Thx

PaScaL


                                                                                                                                               
 From:       James D Miles <jdmiles@xxxxxxxxxx>                                                                                                
                                                                                                                                               
 To:         equinox-dev@xxxxxxxxxxx                                                                                                            
                                                                                                                                               
 Date:       12/03/2007 09:21 PM                                                                                                                
                                                                                                                                               
 Subject:    [equinox-dev] [prov] Version defaults for root IU                                                                                  
                                                                                                                                               





Is it allowed to have multiple versions of a root IU in a metadata
repository?
I created 2 sdk IUs, version 3.4.0.v20071101-2000 and 3.4.0.v20071101-2001

When I run the directory app with either version specified I get the sdk
installed.
When I don't specify the version I get this error
!MESSAGE Can't find a solution where both: Match[requiredCapability:
org.eclipse.equinox.p2.iunamespace/sdk/[3.4.0.v20071101-2000,3.4.0.v20071101-2000]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iunamespace/sdk/[3.4.0.v20071101-2001,3.4.0.v20071101-2001]]
would be satisfied.

It seems that it should be selecting one of these as a default.
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev


_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev

GIF image

GIF image

GIF image