[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] [prov] Version defaults for root IU

Is it allowed to have multiple versions of a root IU in a metadata repository?
I created 2 sdk IUs, version 3.4.0.v20071101-2000 and 3.4.0.v20071101-2001

When I run the directory app with either version specified I get the sdk installed.
When I don't specify the version I get this error
!MESSAGE Can't find a solution where both: Match[requiredCapability: org.eclipse.equinox.p2.iunamespace/sdk/[3.4.0.v20071101-2000,3.4.0.v20071101-2000]] and Match[requiredCapability: org.eclipse.equinox.p2.iunamespace/sdk/[3.4.0.v20071101-2001,3.4.0.v20071101-2001]] would be satisfied.

It seems that it should be selecting one of these as a default.