[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] org.eclipse.equinox.util bundle

Hi all,

I started refactoring of the ProSyst contribution according to the
Eclipse Naming conventions:
1. https://bugs.eclipse.org/bugs/show_bug.cgi?id=209070 ([ds] [graduation] package naming conventions and exports)
2. https://bugs.eclipse.org/bugs/show_bug.cgi?id=209074 ([io] [graduation] package naming conventions and exports)
3. https://bugs.eclipse.org/bugs/show_bug.cgi?id=209076 ([ip] [graduation] package naming conventions and exports)
4. https://bugs.eclipse.org/bugs/show_bug.cgi?id=209077 ([wireadmin] [graduation] package naming conventions and exports)

For the org.eclipse.equinox.util bundle:
I have some comments/questions.

1. Can I change the name to the "org.eclipse.equinox.internal.util"
and kept here only the classes that are needed for more than one bundle?

2. Still we will keep the bundle in the equinox distribution or we will
move the classes to the org.eclipse.equinox.common.jar in the future?

Next week I will work on removing dependencies and some packages from
the util bundle but I need decision about the packaging and naming
prior finishing the work.

Pavlin Dobrev, Research and Development Manager 
ProSyst Labs EOOD, 
48 Vladaiska Str., Sofia, Bulgaria, 
Tel. (+359 2) 954 91 62 . Fax. (+359 2) 953 26 17 
p.dobrev@xxxxxxxxxxx , http://www.prosyst.com 
stay in touch with your product.