[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [prov] compile/javadoc errors in ECF 1.2?

As stated on bug

https://bugs.eclipse.org/bugs/show_bug.cgi?id=207504#c12

We've fixed these javadocs errors so that the more strict prefs no longer show any problems.  It would fix things to use the tag
v20071105-1642 rather than R1_2_0 in the p2 project set files.   There haven't been any material changes to api or impl in these 4 plugins since R1_2_0 tag.

I don't know if there are any policies or conventions against doing this, but I'm not sure what else we can do short of writing over the R1_2_0 tag...which I'm willing to do but would rather not do.

Scott

DJ Houghton wrote:
There is a problem with the preferences so a rebuild sometimes doesn't
happen when you load newer versions so the errors were missed initially.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=207504



equinox-dev-bounces@xxxxxxxxxxx wrote on 11/06/2007 03:10:26 PM:

  
This is a bit off topic, but I've just reinstalled all of the p2
stuff on a brand spankin' new computer, new Eclipse, load the
project set, etc.

ECF 1.2 has javadoc errors (missing @return) that show up as compile
errors in several classes.
I think I had previously just fixed up the settings when I saw these
before, thinking I must have set up some stricter default setting orthe
    
like.
  
But I would have expected not to see these by just loading the
project set into a fresh eclipse.
Has anyone else seen these and this is a bug in either the ECF doc
or the project settings?

    


_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev