|Re: [equinox-dev] [sec] questions about EE for security|
Both John and Rem are correct.
Bundles which want to run on a smaller EE than J2SE-1.4 and have access to the javax.security.auth packages should use import-package (e.g. Import-Package: javax.security.auth). You should not make J2SE-1.4 your required EE only because other bundles you depend on use the EE.
Equinox is a broad community. A large number of our bundles do run on Foundation 1.1/1.0 (and even down to the minimum OSGi EE). But there are some extra features which require higher EEs. Currently parts of the security work in the incubator can only run on J2SE-1.4 or higher. For example, the core extension bundles (org.eclipse.equinox.security.boot.jre14x or org.eclipse.equinox.security.boot.jre15x) are installed into the extension classloader of the VM. This is required because we need to make the our security provider available to the VM and it will only search for providers on the boot classpath or the extension class loader. Unfortunately at that level the code will only have access to classes that are provided by the EE. They do not have the option to import additional packages which may come from other bundles installed in a Framework running on Foundation 1.1 EE.
I opened a couple of bugs against the security bundles. All Equinox bundles should use Import-Package to access packages outside the java.* namespace. We could also split some of the bundles to allow parts of it to run on a Foundation EE.
John Arthorne ---10/31/2007 09:30:11 PM---I think the right approach is to set your bundle's EE to reflect the EE dependencies of *your* bundle, and not the bundles you
John Arthorne <John_Arthorne@xxxxxxxxxx>
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
10/31/2007 09:30 PM
Re: [equinox-dev] [sec] questions about EE for security
|Scott Lewis <slewis@xxxxxxxxxxxxx> |
Sent by: equinox-dev-bounces@xxxxxxxxxxx
10/31/2007 05:53 PM