[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] os.name for Windows 2003 Server

I opened bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=204110 to track this. We will have to feed this through OSGi to get another alias defined for Windows2003

Tom



Inactive hide details for Lukasz Bobowiec ---09/20/2007 04:51:47 AM---Hello,Lukasz Bobowiec ---09/20/2007 04:51:47 AM---Hello,

          Lukasz Bobowiec <Lukasz.Bobowiec@xxxxxxxxxx>
          Sent by: equinox-dev-bounces@xxxxxxxxxxx

          09/20/2007 04:51 AM

          Please respond to
          Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

To

equinox-dev@xxxxxxxxxxx

cc


Subject

[equinox-dev] os.name for Windows 2003 Server


Hello,

I followed the link sent by Peter Kriens about OS names:

http://www2.osgi.org/Specifications/Reference

However on Windows 2003 Server with IBM JRE 1.5 using Peter's properties bundle I obtain the following values:

os.name= "Windows Server 2003" "windows server 2003"

os.arch= "x86" "x86"
os.version= "5.2 build 3790 Service Pack 1""5.2 build 3790 service pack 1"
java.vendor= "IBM Corporation" "ibm corporation"
java.class.version= "49.0" "49.0"
java.version= "1.5.0" "1.5.0"
file.separator= "\" "\"
path.separator= ";" ";"
org.osgi.framework.bootdelegation="*" "*"
...
org.osgi.supports.framework.extension="true" "true"
microedition.configuration="null" "null"
microedition.profiles="null" "null"
org.osgi.framework.executionenvironment="OSGi/Minimum-1.0,OSGi/Minimum-1.1,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5""osgi/minimum-1.0,osgi/minimum-1.1,jre-1.
1,j2se-1.2,j2se-1.3,j2se-1.4,j2se-1.5"
org.osgi.supports.bootclasspath.extension="null" "null"
org.osgi.supports.framework.fragment="null" "null"
org.osgi.supports.framework.requirebundle="null" "null"
org.osgi.framework.version="1.3.0" "1.3.0"
org.osgi.framework.language="pl" "pl"
org.osgi.framework.vendor="Eclipse" "eclipse"
org.osgi.framework.os.name="windows server 2003" "windows server 2003"

org.osgi.framework.os.version="5.2" "5.2"
org.osgi.framework.processor="x86" "x86"

OSGi r4 specification does not mention about such value "Windows Server 2003".

For IBM JRE 1.4.2 os.name is "Windows 2003".

I have lots of bundle with native code and inside the manifest file when I do not append for the header "Bundle-NativeCode" the "Windows Server 2003" value my bundles are invisible (they are not even in INSTALLED state).

After adding to "Windows Server 2003" to Bundle-NativeCode everything works fine.

I found the similar problem that System.getProperty("os.name"), SunVM and J9 reports different names

http://forum.java.sun.com/thread.jspa?threadID=769559&tstart=255

Does OSGi spec. recommend "Windows 2003" or "Windows Server 2003" for Windows Server 2003?

---
Best regards,

Lukasz Bobowiec
Software Engineer, Common Agent Services
lukasz.bobowiec@xxxxxxxxxx
(+48 12) 628 9882

IBM SWG Lab, Cracow, Poland
IBM Polska Sp. z o.o. oddział w Krakowie
ul. Armii Krajowej 18
30 -150 Kraków

NIP: 526-030-07-24
Sąd Rejonowy dla m.st. Warszawy, XIII Wydział Gospodarczy KRS
KRS 0000012941, Kapitał zakładowy: 3.073.600 PLN_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev

GIF image

GIF image

GIF image