[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Launching with Foundation 1.1 VM


I am trying to run a simple Equinox-based product with J9 (Foundation 1.1 profile). Is there some trick to getting running with this setup?  Here is the command line that allows me to make the most progress:

eclipse -product org.eclipse.prov.client.installer.product -debug -vm jre\bin\j9.exe -vmargs -jcl:ppro11 -Dorg.osgi.framework.executionenvironment="OSGi/Minimum-1.0,OSGi/Minimum-1.1,CDC-1.0/Foundation-1.0,CDC-1.1/Foundation-1.1"

With this command line, I get various errors in the log, starting with:

!ENTRY org.eclipse.equinox.app 4 0 2007-09-06 12:17:51.968
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.registry; bundle-version="[3.2.0,4.0.0)"
        at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)
        at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
        at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
        at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:209)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:319)

I have tried invoking the VM directly rather than using eclipse.exe, but get the same result. The same launch runs fine with a 1.4 or Java 5 VM.

Ideas?