[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
RE: [equinox-dev] Versioning problem with HttpService (java.lang.AbstractMethodError)
- From: David Leangen <osgi@xxxxxxxxxxx>
- Date: Tue, 21 Aug 2007 09:52:01 +0900
- Delivered-to: firstname.lastname@example.org
I've been trying to upgrade all my apps to use 2.4 in an attempt to
avoid any conflicts, but it looks like I was being too optimistic to
think that this was possible.
I'm still in the process of trying to get rid of older stuff, so I'll
hopefully have more information soon.
In any case, I thought that it was supposed to be possible to work with
more than one version of the spec, since bundles are isolated from each
Is this therefore not a bug in org.eclipse.equinox.http.servlet?
On Thu, 2007-08-16 at 13:55 -0400, Simon Kaegi wrote:
> Hi David,
> It might be a good idea to see if we can figure out which version of the
> servlet API is bound to the imports for:
> org.eclipse.osgi.services (can resolve against Servlet API>= 2.1)
> org.eclipse.equinox.http.servlet (can resolve against Servlet API >= 2.3)
> Jetty 5.1requires Servlet 2.4 so that's what I meant when I said there was
> potential for problems since org.eclipse.equinox.http.jetty will also
> import classes from org.eclipse.equinox.http.servlet.
> equinox-dev-bounces@xxxxxxxxxxx wrote on 08/16/2007 11:15:54 AM:
> > > Apart from that all I can think of is interference if Servlet 2.3
> > > is visible in another bundle.
> > Actually, yes, it is... I am using 2.3 in other bundles.
> > Why, does this have some effect? Seems to me that it shouldn't...
> > Cheers,
> > Dave
> > _______________________________________________
> > equinox-dev mailing list
> > equinox-dev@xxxxxxxxxxx
> > https://dev.eclipse.org/mailman/listinfo/equinox-dev
> equinox-dev mailing list