[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Versioning problem with HttpService (java.lang.AbstractMethodError)

Hi David,

It might be a good idea to see if we can figure out which version of the
servlet API is bound to the imports for:
org.eclipse.osgi.services (can resolve against Servlet API>= 2.1)
org.eclipse.equinox.http.servlet (can resolve against Servlet API >= 2.3)

Jetty 5.1requires Servlet 2.4 so that's what I meant when I said there was
potential for problems since org.eclipse.equinox.http.jetty will also
import classes from org.eclipse.equinox.http.servlet.

-Simon

equinox-dev-bounces@xxxxxxxxxxx wrote on 08/16/2007 11:15:54 AM:

>
> > Apart from that all I can think of is interference if Servlet 2.3
> > is visible in another bundle.
>
> Actually, yes, it is... I am using 2.3 in other bundles.
>
> Why, does this have some effect? Seems to me that it shouldn't...
>
>
> Cheers,
> Dave
>
>
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev