[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] [prov] need a 1.5 JVM if generating metadata from latest code


In case anyone else is scratching their head thinking "why aren't my launch configs working anymore?...."  
If you are running the latest provisioning code from HEAD, you will need to use a 1.5 JVM in your launch configs.  Some of the new repo code has a dependency on 1.5.  The failure was cryptic to me, it looks something like:

!ENTRY org.eclipse.osgi 4 0 2007-08-13 11:56:11.432
!MESSAGE Application error
!STACK 1
java.lang.NoSuchMethodError: java.lang.Class.getCanonicalName()Ljava/lang/String;
        at org.eclipse.equinox.internal.prov.metadata.repository.URLMetadataRepository.<clinit>(URLMetadataRepository.java:34)
        at org.eclipse.equinox.prov.metadata.repository.MetadataRepositoryManager.restoreRepositories(MetadataRepositoryManager.java:88)
        at org.eclipse.equinox.prov.metadata.repository.MetadataRepositoryManager.<init>(MetadataRepositoryManager.java:25)