[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] AOSGI Deploy a product


It looks like you are missing the org.eclipse.osgi_<version>.jar and org.aspectj.osgi_<version>.jar from your product.  Verify that these are included in your exported product's plugins directory.

Tom




"Sebastian Staack" <Sebastian.Staack@xxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

06/07/2007 05:22 AM

Please respond to
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

To
<equinox-dev@xxxxxxxxxxx>
cc
Subject
[equinox-dev] AOSGI Deploy a product





I have a problem deploying a product which uses AOSGI. If i export such a product with the export wizard and start it i get following error message:
 
!SESSION Wed Jun 06 12:21:27 CEST 2007 -----------------------------------------
!ENTRY org.eclipse.core.launcher 4 0 2007-06-06 12:21:27.576
!MESSAGE Could not find extension: org.aspectj.osgi
!ENTRY org.eclipse.core.launcher 4 0 2007-06-06 12:21:27.576
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:333)
at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)

 
I havn't any idea what is wrong. Can you please help me?_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev