[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Null pointer exception Equinox 3.2 JVM J9


I have not encountered that error.  Please open a bug and give some details on how you are launching Equinox.  Are you using the eclipse.exe?  Are you using the startup.jar?  Or are you just using java -jar org.eclipse.osgi_3.2.0.jar?

Thanks.

Tom



Laurent Broqué <laurent.broque@xxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

07/21/2006 04:00 AM

Please respond to
laurent.broque@xxxxxxxxx; Please respond to
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

To
equinox-dev@xxxxxxxxxxx
cc
Subject
[equinox-dev] Null pointer exception Equinox 3.2 JVM J9





There is no problem lauching equinox 3.2 on a "standard" JVM (sun JDK1.5), but
we cant launch it with J9 (version 2.2, JVM 1.3.0), we have a NPE due to
IllegalStateException in org.eclipse.osgi.internal.baseadaptor.BaseStorage :

   private void checkSystemState(State state) {
      ...
     BundleDescription systemBundle = state.getBundle(0);
       if (systemBundle == null || !systemBundle.isResolved()){
           // this would be a bug in the framework
->           throw new IllegalStateException();
       }

Is there someOne with the same problem. I don't exactly undestand why we have
this exception fired ...

Is it a bug ?
--
Thanks
LBR
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev