[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Eclipse 3.2 migration problem

Hi

I have migrated all my 3.1 plugins to 3.2 and the line coverage options is working. I am facing a problem while launching any application e.g. Eclips runtime, junit test etc. I get the following error's in the logs

!SESSION 2006-07-07 11:25:18.102 ------------------------------
-----------------
eclipse.buildId=unknown
java.version=1.4.2_10
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.sdk.ide -pdelaunch
Command-line arguments:  -product org.eclipse.sdk.ide -data C:\Projects\TI\work\eclipse3.2\TI_workspace1/../runtime-EclipseApplication -dev file:C:/Projects/TI/work/eclipse3.2/TI_workspace1/.metadata/.plugins/org.eclipse.pde.core/Eclipse Application/dev.properties -pdelaunch -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 2006-07-07 11:25:18.618
!MESSAGE Error installing bundle: reference:file:plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar/
!STACK 0
org.osgi.framework.BundleException: No match is available for the required execution environment: CDC-1.0/Foundation-1.0,J2SE-1.3
    at org.eclipse.osgi.framework.internal.core.Framework.verifyExecutionEnvironment(Framework.java:605)
    at org.eclipse.osgi.framework.internal.core.Framework.createAndVerifyBundle(Framework.java:560)
    at org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(Framework.java:822)
    at org.eclipse.osgi.framework.internal.core.Framework$2.run(Framework.java:737)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:788)
    at org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:732)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:221)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.installBundles(EclipseStarter.java:956)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBundles(EclipseStarter.java:543)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:288)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:159)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    at org.eclipse.core.launcher.Main.run(Main.java:973)
    at org.eclipse.core.launcher.Main.main(Main.java:948)

!ENTRY initial@reference:file:../TI_workspace1/org.eclipse.update.configurator/ 0 0 2006-07-07 11:25:18.727
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.update.internal.configurator.ConfigurationActivator.start() of bundle org.eclipse.update.configurator.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1013)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:969)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:316)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:337)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1024)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:574)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:496)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:456)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)
Caused by: java.lang.Exception: Cannot initialize the Update Configurator
    at org.eclipse.update.internal.configurator.ConfigurationActivator.initialize(ConfigurationActivator.java:89)
    at org.eclipse.update.internal.configurator.ConfigurationActivator.start(ConfigurationActivator.java:67)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:994)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:988)
    ... 10 more
Root exception:
java.lang.Exception: Cannot initialize the Update Configurator
    at org.eclipse.update.internal.configurator.ConfigurationActivator.initialize(ConfigurationActivator.java:89)
    at org.eclipse.update.internal.configurator.ConfigurationActivator.start(ConfigurationActivator.java:67)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:994)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:988)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:969)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:316)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:337)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1024)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:574)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:496)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:456)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

!ENTRY org.eclipse.osgi 2006-07-07 11:25:18.837
!MESSAGE Startup error
!STACK 1
java.lang.IllegalStateException: Bundle initial@reference:file:../TI_workspace1/org.eclipse.update.configurator/ [2] is not active.
    at org.eclipse.core.runtime.adaptor.EclipseStarter.ensureBundlesActive(EclipseStarter.java:410)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:297)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:159)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
    at org.eclipse.core.launcher.Main.run(Main.java:973)
    at org.eclipse.core.launcher.Main.main(Main.java:948)


What do i do in this case can somebody help me out?

regards,
Sheldon