[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Another bug in resolver during "update" ?

The Pax Wicket (the one with the many exports) bundle imports "javax.crypto" 
package, and that is resolved fine during the initial install. However, if I 
do a "update" on that bundle, I get the following stack trace.

 * The console reports that the package is exported by the System bundle.
 * org.ops4j.pax.wicket.service is exported by the bundle that we update.
 * Using the Equinox version from Bugzilla 144730 dated 6/6/06


org.osgi.framework.BundleException: The bundle could not be resolved. Reason: 
Missing Constraint: Import-Package: javax.crypto; version="0.0.0", Package 
uses conflict: Import-Package: org.ops4j.pax.wicket.service; version="0.0.0", 
Missing Constraint: Import-Package: org.ops4j.pax.wicket.service; 
version="0.0.0"
        at 
org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:294)
        at 
org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:256)
        at 
org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:239)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at 
org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:145)
        at 
org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:293)
        at 
org.eclipse.osgi.framework.internal.core.FrameworkConsole.console(FrameworkConsole.java:278)
        at 
org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:213)
        at java.lang.Thread.run(Thread.java:595)


Cheers
Niclas