[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] debugging org.eclipse.osgi


In eclipse 3.1, you need to create an Eclipse Application launc configuration. Specify -noExit -console as program arguments. In the plug-ins tab, pick the "choose plug-ins..." option and select the plug-ins you want to run. Finally, run :-)



"Arjun Singh" <aasingh@xxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

03/21/2006 05:45 PM

Please respond to
Equinox development mailing list

To
"'Equinox development mailing list'" <equinox-dev@xxxxxxxxxxx>
cc
Subject
RE: [equinox-dev] debugging org.eclipse.osgi





I can run/debug in Eclipse using 3.2 M5a.  But is there any way to do this using 3.1?  How did everybody run/debug before Eclipse 3.2?  The reason I ask is that I’m trying to use the AspectJ development tools, which don’t work so well yet for version 3.2, but work fine for 3.1.  
 
Thanks,
Arjun
 



From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Thomas Watson
Sent:
Saturday, March 18, 2006 5:47 AM
To:
Equinox development mailing list
Subject:
RE: [equinox-dev] debugging org.eclipse.osgi

 

Make sure you have one of the latest Eclipse 3.2 SDK builds.  I recommend the 3.2 M5a build.  The Equinox OSGi Framework launcher is new to PDE in 3.2.  You must have PDE (Plug-in Development Environment) installed.  PDE is included in the SDK so if you download that it should be included.


Tom



"Arjun Singh" <aasingh@xxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

03/17/2006 08:14 PM


Please respond to
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>


To
"'Equinox development mailing list'" <equinox-dev@xxxxxxxxxxx>
cc
 
Subject
RE: [equinox-dev] debugging org.eclipse.osgi

 


   





When I select Run > Debug…, I don’t see an option for Equinox OSGi Framework in the configurations window.  Do you mean debug it as a java application?  When I try that, I get a runtime exception indicating that the system manifest bundle is cannot be found.  Is there a plugin I need to install so that I see an option for debugging as Equinox OSGi Framework?

 
Thanks for the help,

Arjun

 

 



From:
equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Pascal Rapicault
Sent:
Friday, March 17, 2006 3:42 PM
To:
Equinox development mailing list
Cc:
'Equinox development mailing list'; equinox-dev-bounces@xxxxxxxxxxx
Subject:
Re: [equinox-dev] debugging org.eclipse.osgi

 


Load osgi into your workspace. Then if you just need plain osgi, do Run > Debug... > Equinox OSGi Framework. Make sure osgi is selected, click the debug button. You are debugging :-)


PaScaL

"Arjun Singh" <aasingh@xxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

03/17/2006 05:22 PM

 


Please respond to
Equinox development mailing list

 


To
"'Equinox development mailing list'" <equinox-dev@xxxxxxxxxxx>
cc
 
Subject
[equinox-dev] debugging org.eclipse.osgi


 

 


   





Hi,


How can I debug the org.eclipse.osgi project from within Eclipse?  What do I need to do to my run configuration?  


Thanks,

Arjun

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev