[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Shipping equinox runtime



Here a question related to build/shipping structure of plug-ins:

Equinox runtime is currently (and probably correctly) designated as
'alternative Eclipse run-time' indicating that Eclipse 3.0 users will have
a choice of runtimes. Consequently, other Eclipse plug-ins (PDE in
particular) cannot count on Equinox being there. For this reason, we plan
to create OSGi PDE plug-ins and tap use extension points to plug the
support in. If OSGi PDE plug-ins are not present, PDE will be OSGi-dumb.
Dropping the plug-ins in will make PDE OSGi-smart. This way, we can include
PDE OSGi-specific plug-ins into the overall OSGi Eclipse 3.0 deliverable
(assuming that there will also be Eclipse 3.0 with the 'classic' Eclipse
runtime).

Does this make sense?

Regards,

Dejan Glozic, Ph.D.
Manager, Eclipse Platform Components
D2/MY7/8200/MKM
IBM Canada Ltd.
Tel. 905 413-2745  T/L 969-2745
Fax. 905 413-4854