[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [egit-dev] Install Error

Emily Cohen wrote:
> I am getting the following error when trying to install egit from
> http://download.eclipse.org/egit/updates
> Cannot complete the install because of a conflicting dependency.
> Software being installed: EGit Import Support
> (org.eclipse.egit.import.
> feature.group
> Software currently installed: Eclipse SDK 3.7.2.M20120208-0800
> (org.eclipse.sdk.ide 3.7.2.M20120208-0800)
> Only one of the following can be installed at once:
> Team Support Core 3.6.100.v20120524-0627 (org.eclipse.team.core
> 3.6.100.v20120524-0627)
> Team Support Core 3.6.0.I20110525-0800 (org.eclipse.team.core
> 3.6.0.I20110525-0800)
> Cannot satisfy dependency:
> From: EGit Import Support
> (org.eclipse.egit.import.feature.group
> To: org.eclipse.team.core 3.6.100
> Does egit not support eclipse sdk 3.7? Or is there something else
> going on? I've looked through the documentation and forums and have
> not seen anything regarding this.

The "EGit Import Support" feature requires at least Eclipse 3.8/4.2.
To install on 3.7, just leave this feature unchecked. You probably
don't need the functionality, see here for a description:


There's an open change in review to change the feature name
and update the description (other users have also had this problem):


  Robin Stocker