[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [egit-dev] urgent help needed :(


On 04/03/12 15:17, Matthias Sohn wrote:
> 2012/4/3 Markus Duft <markus.duft@xxxxxxxxxx <mailto:markus.duft@xxxxxxxxxx>>
> 
> 
> 
>     On 04/03/12 14:40, Matthias Sohn wrote:
>     > 2012/4/3 Markus Duft <markus.duft@xxxxxxxxxx <mailto:markus.duft@xxxxxxxxxx> <mailto:markus.duft@xxxxxxxxxx <mailto:markus.duft@xxxxxxxxxx>>>
>     >
>     >     Hey!
>     >
>     >     I just built new versions of egit and jgit from todays master. i tried them and everything seemed to work, so i rolled out the version, and suddenly a whole bunch of workspaces "died", meaning that eclipse wont start on this workspaces anymore. attached is the .metadata/.log for such a session. i don't get a workbench at all, but only a "see .metadata/.log" error message.
>     >
>     >     bad enough, my egit/jgit workspace is one of the broken ones, so i cannot even start this... from the log it looks like it doesn't like the up/down arrow decorations, but i can't imagine that those are the problem, because after all they have been in for a while.
>     >
>     >     interesting enough, it has to be something with the workspace metadata, because i can fire up another workspace with the same eclipse just fine... ?! i'm confused...
>     >
>     >
>     > there are basically 2 types of problems reported, the first one looks like a cleanup issue in JDT,
>     > the second one:
>     > java.lang.Error: Unresolved compilation problem:
>     > Invalid character constant
>     >
>     > at org.eclipse.egit.ui.internal.GitLabelProvider.formatBranchTrackingStatus(GitLabelProvider.java:70)
>     > at org.eclipse.egit.ui.internal.GitLabelProvider.getStyledTextFor(GitLabelProvider.java:179)
>     > at org.eclipse.egit.ui.internal.repository.RepositoriesViewLabelProvider.getStyledText(RepositoriesViewLabelProvider.java:345)
>     > at org.eclipse.ui.internal.navigator.extensions.SafeDelegateCommonLabelProvider.getStyledText(SafeDelegateCommonLabelProvider.java:118)
>     > at org.eclipse.ui.internal.navigator.NavigatorContentServiceLabelProvider.findStyledText(NavigatorContentServiceLabelProvider.java:165)
>     > at org.eclipse.ui.internal.navigator.NavigatorContentServiceLabelProvider.getStyledText(NavigatorContentServiceLabelProvider.java:151)
>     > at org.eclipse.ui.internal.navigator.NavigatorDecoratingLabelProvider$StyledLabelProviderAdapter.getStyledText(NavigatorDecoratingLabelProvider.java:68)
>     > at org.eclipse.jface.viewers.DelegatingStyledCellLabelProvider.getStyledText(DelegatingStyledCellLabelProvider.java:195)
>     > at org.eclipse.jface.viewers.DecoratingStyledCellLabelProvider.getStyledText(DecoratingStyledCellLabelProvider.java:192)
>     > at org.eclipse.ui.internal.navigator.NavigatorDecoratingLabelProvider.getText(NavigatorDecoratingLabelProvider.java:222)
>     > at org.eclipse.jface.viewers.ViewerComparator.compare(ViewerComparator.java:135)
>     > at org.eclipse.ui.navigator.CommonViewerSorter.compare(CommonViewerSorter.java:140)
>     >
>     > seems to be caused by your platform not being able to resolve the up/down arrow characters.
>     >
>     > - Did you try to use a different character instead ?
> 
>     thats what i'm trying now.
> 
>     > - How did you build your EGit version ?
> 
>     i have an update-site project which i use to build an egit and jgit update site (it worked out well 100 times before, and i didn't change anything...).
> 
> 
> is this a different one than org.eclipse.egit-updatesite ? 

yes, i cannot use this as it doesn't work from within the IDE:

Processing inclusion from feature org.eclipse.egit.source: Unable to find plug-in: org.eclipse.egit.core.source_0.0.0. Please check the error log for more details.

i just replaced the two chars with '<' and '>' and it works now - i'll investigate some more on why this happens.

Markus

> 
> -- 
> Matthias