[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [eclipselink-dev] How to import eclipselink to eclipse?

What are you trying to achieve by importing the eclipse projects. It looks like you have imported quite a lot of projects and I'd like to help you pare down the list.

-Tom

On 29/03/2012 6:26 AM, Péntek Gábor wrote:
Hi All,

I am trying to build eclipselink from the trunk in order to resolve this issue:
http://www.eclipse.org/forums/index.php?t=rview&goto=825210#msg_825210
<http://www.eclipse.org/forums/index.php?t=rview&goto=825210#msg_825210>

The solution is ready but I have some trouble with building the project from
eclipse.

Ant build is working now, but it took some time since did not find a document
describing the whole process and the information needed was spread among several
wiki pages.

I have done the following:
checked out eclipselink trunk.
ran an ant build.
copied the contents of the trunk/plugins directory to eclipse/plugins
imported the projects suggested on http://wiki.eclipse.org/EclipseLink/Building

Eclipse gave the following error messages:
Description    Resource    Path    Location    Type
Project 'eclipselink.core.test' is missing required Java project:
'javax.persistence 2.1.0'    eclipselink.core.test        Build path    Build
Path Problem
Project 'eclipselink.core.test' is missing required Java project:
'javax.xml.bind'    eclipselink.core.test        Build path    Build Path Problem
Project 'eclipselink.jpa.modelgen.test' is missing required Java project:
'javax.persistence 2.1.0'    eclipselink.jpa.modelgen.test        Build path
Build Path Problem
Project 'eclipselink.jpa.modelgen.test' is missing required library:
'/eclipselink.jpa.test/eclipselink-tests.jar'
eclipselink.jpa.modelgen.test        Build path    Build Path Problem
Project 'eclipselink.jpa.test' is missing required Java project:
'javax.persistence 2.1.0'    eclipselink.jpa.test        Build path    Build
Path Problem
Project 'eclipselink.jpa.test' is missing required Java project:
'javax.xml.bind'    eclipselink.jpa.test        Build path    Build Path Problem
Project 'eclipselink.moxy.test' is missing required Java project:
'javax.activation'    eclipselink.moxy.test        Build path    Build Path Problem
Project 'eclipselink.moxy.test' is missing required Java project:
'javax.mail'    eclipselink.moxy.test        Build path    Build Path Problem
Project 'eclipselink.moxy.test' is missing required Java project:
'javax.xml.bind'    eclipselink.moxy.test        Build path    Build Path Problem
Project 'eclipselink.moxy.test' is missing required Java project:
'javax.xml.stream'    eclipselink.moxy.test        Build path    Build Path Problem
Project 'eclipselink.utils.jaxb' is missing required Java project:
'com.sun.xml.bind'    eclipselink.utils.jaxb        Build path    Build Path Problem
Project 'org.eclipse.persistence.jpa.modelgen' is missing required Java project:
'javax.persistence 2.1.0'    org.eclipse.persistence.jpa.modelgen        Build
path    Build Path Problem
Project 'org.eclipse.persistence.moxy.dynamicxjc' is missing required Java
project: 'com.sun.xml.bind'    org.eclipse.persistence.moxy.dynamicxjc
Build path    Build Path Problem
Project 'org.eclipse.persistence.moxy.dynamicxjc' is missing required Java
project: 'javax.xml.bind'    org.eclipse.persistence.moxy.dynamicxjc
Build path    Build Path Problem
Unbound classpath variable:
'ECLIPSELINK_HOME/plugins/com.sun.tools.xjc_2.2.0.jar' in project
'eclipselink.utils.jaxb'    eclipselink.utils.jaxb        Build path    Build
Path Problem
Unbound classpath variable:
'ECLIPSELINK_HOME/plugins/com.sun.tools.xjc_2.2.0.jar' in project
'org.eclipse.persistence.moxy.dynamicxjc'
org.eclipse.persistence.moxy.dynamicxjc        Build path    Build Path Problem
Unbound classpath variable: 'JAXRS_LIB' in project 'eclipselink.jpa.test'
eclipselink.jpa.test        Build path    Build Path Problem
Build path specifies execution environment J2SE-1.5. There are no JREs installed
in the workspace that are strictly compatible with this environment.
javax.validation        Build path    JRE System Library Problem
Build path specifies execution environment J2SE-1.5. There are no JREs installed
in the workspace that are strictly compatible with this environment.
org.eclipse.persistence.core.jpql        Build path    JRE System Library Problem
Build path specifies execution environment J2SE-1.5. There are no JREs installed
in the workspace that are strictly compatible with this environment.
org.eclipse.persistence.jpa.jpql.test        Build path    JRE System Library
Problem
Build path specifies execution environment J2SE-1.5. There are no JREs installed
in the workspace that are strictly compatible with this environment.
org.eclipse.persistence.jpa.osgi        Build path    JRE System Library Problem


For example javax.persistence is imported, but it has version 2.0.0


Thanks in advance! Gábor


_______________________________________________ eclipselink-dev mailing list eclipselink-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/eclipselink-dev