[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipse.org-planning-council] Re: EMF usage in TPTP 4.4.0

Harm,
While I await the the results of your testing, my understanding from talking to Ed and Nick recently and listening to their explanations of this change to the Councils back in June and again in October was that the runtime will continue to work on JVM 1.4. So as long as you do not regenerate your models, the code will continue to work on JVM 1.4 without change or reduced functionality. I also assume, but have not verified, that you could always re-generate your models using an older EMF and thus continue to use JVM 1.4 with newer models.

The part that puzzles me most is how our process broke down - the EMF team clearly brought this JVM 4/5 issue forward over seven months ago so why is it suddenly a surprise and a blocking issue for Europa? I'd like to resolve that mystery so that we, collectively, don't have similar problems from other known-in-advance project interactions.

- Bjorn

Harm Sluiman wrote:

I believe you have it correct Bjorn. The concern is that given that many of the higher level tools (TPTP, WTP, BIRT) use EMF, the "reduced functionality" may be rather significant. It seems that with  a common component like EMF requiring 5 the majority of configurations above base JDT will require 5. This can make the out of the box experience for a default 1.4 user problematic.