[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[eclipse.org-architecture-council] [Bug 358917] [Naming Conventions] enforce different id for plugins and feature

https://bugs.eclipse.org/bugs/show_bug.cgi?id=358917
Product/Component: Community / Architecture Council

Wayne Beaton <wayne@xxxxxxxxxxx> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |wayne@xxxxxxxxxxx
          Component|Process                     |Architecture Council
         AssignedTo|emo@xxxxxxxxxxx             |eclipse.org-architecture-co
                   |                            |uncil@xxxxxxxxxxx

--- Comment #1 from Wayne Beaton <wayne@xxxxxxxxxxx> 2011-09-26 11:46:04 EDT ---
The convention is to use org.eclipse.<projectshortname>.*, e.g.
org.eclipse.tycho.core. This is similar to the guidelines for package naming.

We should update the Naming Conventions wiki page to reflect this.

I am reassigning to the Architecture Council for their comments.

-- 
Configure bugmail: https://bugs.eclipse.org/bugs/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.