[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ecf-dev] R-HEAD build failing

Hi Folks,

Given the discussion with David Williams on [1], I think what I'm going to do is to release the unpacked repo built from R-HEAD-sdk-feature yesterday for ECF 3.12.1 tomorrow (Friday pacific time).  

This way we can put 3.12.1 in the can and continue to work on fixing the pack200 for another maintenance release (3.12.2) as soon as the pack200 can be fixed.

If you have any objections to this plan, please say so now.     I would appreciate it if those with knowledge/expertise WRT the builder config could continue to work on this until we figure out what to change in our builder to deal with the pack200 problems described below.

Thanksinadvance,

Scott

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=448916#c51

On 1/13/2016 7:51 PM, Scott Lewis wrote:
Hi Folks,

Here's the latest:

1) I fooled around with changing the version of java (1.6, 1.7, 1.8) used to run buckminster for the R-HEAD-sdk-feature and that didn't change things at all (same exception as below)
2) I turned off pack200 by setting:  SITE_PACK200=false for the R-HEAD-sdk-feature, and the build completed successfully [1]

Obviously pack200 is off, however, so I'm not sure that we can use this for a release.   I will check with the powers that be.

But I would appreciate it if Wim and/or Markus could take another look at the pack200 stuff...and the compatibility across java versions, etc (as David Williams points to).   One problem I faced in doing this, however, was that the pack200 code was called from within a Buckminster action (as can be seen from the stack trace), and I don't know how (or even whether) this can be configured to use some specific pack200 version.

Thanks,

Scott

[1] https://build.ecf-project.org/jenkins/job/R-HEAD-sdk.feature/185/

On 1/13/2016 9:28 AM, Scott Lewis wrote:
Hi,

I wanted to let Wim and Markus know that I asked David Williams to comment on this issue on this bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=448916

See comments 47+:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=448916#c46

He seems to think that it's because of java6 tools:

https://dev.eclipse.org/mhonarc/lists/cbi-dev/msg01560.html

For my information:   to give this a try, where would the configuration above be provided in our java6 builder?

Please coordinate our efforts over next days via either this list or direct via Skype.

Thanks,

Scott

On 1/13/2016 6:39 AM, Wim Jongman wrote:
Ok I will ask that as well.

On Wed, Jan 13, 2016 at 3:37 PM, Markus Alexander Kuppe <ecf-dev_eclipse.org@xxxxxxxxxxx> wrote:
On 13.01.2016 15:11, Wim Jongman wrote:
> Let's first reboot the machine. It is up for 1100+ days and slow as a
> turtle with a broken leg. Log files are rotated indefinitely. This
> should be fixed too,
>
> I will ask OSUOSL to take care of that as well.

Hi Wim,

thanks for taking this on. Note that I contacted OSUOSL a while back to
have Java updated to 1.8 but they never responded.

Cheers
Markus
_______________________________________________
ecf-dev mailing list
ecf-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/ecf-dev



_______________________________________________
ecf-dev mailing list
ecf-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/ecf-dev



_______________________________________________
ecf-dev mailing list
ecf-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/ecf-dev



_______________________________________________
ecf-dev mailing list
ecf-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/ecf-dev