[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[ecf-dev] jdom library version

Hi Folks,

The jdom library version that we have a CQ for is 1.0...here is the piggyback CQ submitted by Pavel Samolisov for jdom 1.

https://dev.eclipse.org/ipzilla/show_bug.cgi?id=4508

However, it seems that ECF's build is using jdom 1.1.1...and that's what's in our 3.5.1 repo...i.e:

http://download.eclipse.org/rt/ecf/3.5Test/site.p2/plugins/org.jdom_1.1.1.v201101151400.jar.pack.gz

Wayne's EF IP review found this...as we need to have a piggyback CQ for all new versions of Orbit libs (i.e. one for jdom 1.1.1 usage rather than 1.0) so I've created a new ECF piggyback CQ for use of jdom 1.1.1:

https://dev.eclipse.org/ipzilla/show_bug.cgi?id=5193

Hopefully we'll be able to get this piggyback CQ approved right away...and use jdom 1.1.1. I'll let all know if there turns out to be some issue with that. I do want to make sure (Pavel?) that the ECF component that uses jdom can use 1.1.1 (rather than 1.0). I'm assuming so, given the automated tests pass, but I want to make sure.

In any case...for future: committers please be aware that every time a version change occurs in an Orbit library, we need to submit a new piggyback CQ to use of the new/updated version of the library.

Thanks,

Scott