[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ecf-dev] r-osgi - Multiplexer must not be constructed from NULL primary endpoint

On 10/18/2010 03:03 PM, Martin Petzold wrote:
>  Hey,
> 
> i've got some problems using ECF with the r-osgi provider. The
> "org.eclipse.ecf.internal.examples.remoteservices.hello.host.HelloHostApplication
> example" does work with zookeeper&r-osgi (Hello Service Host
> (zookeeper,rosgi).product).
> 
> For my Plug-In (Eclipse Helios, ECF 3.3.1.v20100913-1814, no special
> command line arguments) i did this in my Activator start():
> 
> private static final String CONTAINER_TYPE = "ecf.r_osgi.peer";
> public static final String CONTAINER_ID = "r-osgi://localhost:9278";
> [...]
> // Register a (remote) node service
> Properties properties = new Properties();
> properties.put("service.exported.interfaces", "*");
> properties.put("service.exported.configs", CONTAINER_TYPE);
> properties.put("org.eclipse.ecf.containerFactoryArgs", CONTAINER_ID);
> this.nodeService = bundleContext.registerService(Node.class.getName(),
> new DefaultNode(), properties);
> 
> And i get this Exception...can anyone help me, i'm realy confused!
> 
> !ENTRY R-OSGi Proxy Bundle generated for Endpoint
> r-osgi://jumper:9280#53 4 0 2010-10-18 14:50:04.960
> !MESSAGE
> !STACK 0
> org.osgi.framework.BundleException: Exception in
> proxy.jumper_jciafd.de.ooflex.devsosgi.NodeImpl.start() of bundle R-OSGi
> Proxy Bundle generated for Endpoint r-osgi://jumper:9280#53.
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:806)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> Caused by: java.lang.IllegalArgumentException: Multiplexer must not be
> constructed from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.jumper_jciafd.de.ooflex.devsosgi.NodeImpl.start(Unknown Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     ... 11 more
> Root exception:
> java.lang.IllegalArgumentException: Multiplexer must not be constructed
> from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.jumper_jciafd.de.ooflex.devsosgi.NodeImpl.start(Unknown Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> 
> !ENTRY R-OSGi Proxy Bundle generated for Endpoint
> r-osgi://jumper:9279#53 4 0 2010-10-18 14:50:04.962
> !MESSAGE
> !STACK 0
> org.osgi.framework.BundleException: Exception in
> proxy.jumper_jchjfd.de.ooflex.devsosgi.NodeImpl.start() of bundle R-OSGi
> Proxy Bundle generated for Endpoint r-osgi://jumper:9279#53.
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:806)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> Caused by: java.lang.IllegalArgumentException: Multiplexer must not be
> constructed from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.jumper_jchjfd.de.ooflex.devsosgi.NodeImpl.start(Unknown Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     ... 11 more
> Root exception:
> java.lang.IllegalArgumentException: Multiplexer must not be constructed
> from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.jumper_jchjfd.de.ooflex.devsosgi.NodeImpl.start(Unknown Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> 
> !ENTRY org.eclipse.ecf.provider.zookeeper 4 0 2010-10-18 14:50:04.965
> !MESSAGE
> !STACK 0
> org.osgi.framework.BundleException: The bundle
> "org.eclipse.ecf.provider.zookeeper_1.0.0.v20100913-1814 [49]" could not
> be resolved. Reason: Missing Constraint: Import-Package:
> org.apache.zookeeper; version="0.0.0"
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> 
> !ENTRY R-OSGi Proxy Bundle generated for Endpoint
> r-osgi://jumper:9278#53 4 0 2010-10-18 14:50:04.979
> !MESSAGE
> !STACK 0
> org.osgi.framework.BundleException: Exception in
> proxy.jumper_jchifd.de.ooflex.devsosgi.NodeImpl.start() of bundle R-OSGi
> Proxy Bundle generated for Endpoint r-osgi://jumper:9278#53.
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:806)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> Caused by: java.lang.IllegalArgumentException: Multiplexer must not be
> constructed from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.jumper_jchifd.de.ooflex.devsosgi.NodeImpl.start(Unknown Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     ... 11 more
> Root exception:
> java.lang.IllegalArgumentException: Multiplexer must not be constructed
> from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.jumper_jchifd.de.ooflex.devsosgi.NodeImpl.start(Unknown Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> 
> !ENTRY R-OSGi Proxy Bundle generated for Endpoint
> r-osgi://localhost:9278#53 4 0 2010-10-18 14:50:04.980
> !MESSAGE
> !STACK 0
> org.osgi.framework.BundleException: Exception in
> proxy.localhost_jchifd.de.ooflex.devsosgi.NodeImpl.start() of bundle
> R-OSGi Proxy Bundle generated for Endpoint r-osgi://localhost:9278#53.
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:806)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> Caused by: java.lang.IllegalArgumentException: Multiplexer must not be
> constructed from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.localhost_jchifd.de.ooflex.devsosgi.NodeImpl.start(Unknown
> Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     ... 11 more
> Root exception:
> java.lang.IllegalArgumentException: Multiplexer must not be constructed
> from NULL primary endpoint
>     at
> ch.ethz.iks.r_osgi.impl.ChannelEndpointMultiplexer.<init>(ChannelEndpointMultiplexer.java:84)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getMultiplexer(RemoteOSGiServiceImpl.java:892)
>     at
> ch.ethz.iks.r_osgi.impl.RemoteOSGiServiceImpl.getEndpoint(RemoteOSGiServiceImpl.java:869)
>     at proxy.localhost_jchifd.de.ooflex.devsosgi.NodeImpl.start(Unknown
> Source)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:374)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1067)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:561)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:546)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:459)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
>     at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:440)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:227)
>     at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:337)
> 
> Thanks!
> 
> Martin

Hi Martin,

this might be related to bug #248545 [0]. Can you check if a recent
build [1] fixes it for you?

But you might also want to investigate why it fails to resolve zookeeper
dependencies. Is org.apache.zookeeper resolved?

>
> !ENTRY org.eclipse.ecf.provider.zookeeper 4 0 2010-10-18 14:50:04.965
> !MESSAGE
> !STACK 0
> org.osgi.framework.BundleException: The bundle
> "org.eclipse.ecf.provider.zookeeper_1.0.0.v20100913-1814 [49]" could not
> be resolved. Reason: Missing Constraint: Import-Package:
> org.apache.zookeeper; version="0.0.0"
>     at

Markus

[0] https://bugs.eclipse.org/248545
[1] http://download.ecf-project.org/repo/N-HEAD-sdk.feature/