[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ecf-dev] objectweb.asm 3.1

Scott Lewis wrote:
Our import package in the r-osgi bundle currently looks like this:

Import-Package: org.objectweb.asm;version="[3.0.0,3.1.0)",

So with this markup, 3.1 is *not* included in the version range. If I set the version range to include 3.1 everything compiles ok using the platform provided 3.1. I haven't done any runtime testing though.

So, my question is: can/could we use 3.1 rather than 3.0? If so, it would save us some distribution size/dependency.

It is restricted to 3.0 because of https://bugs.eclipse.org/255305. Maybe Jan knows a way to work around it so we can move up to 3.1.


Markus