[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[ecf-dev] Re: EMF and ECF 3.0 build

Scott Lewis wrote:
> Hi Markus,
> 
> I saw that a number of additions (e.g. discovery.ui.*) went in during
> our night last night.  Thanks for the additions and for updating the
> releng project set files.
> 
> So that everyone can get the necessary stuff, for the new EMF
> dependencies would you let everyone know (via ecf-dev mailing list that 
> they
> 
> c) specify which version(s) of EMF will work/are needed

EMF >= 2.2

> d) It would actually also be very nice to put only the necessary EMF
> plugins into the ecf project set files...so that the EMF source/bundles
> are loaded into workspace. 

I've added the EMF dependencies to both map files (anonymous as well as
extssh) and set the version to 2.4 (technically ECF discovery UI works
with EMF >=2.2 though, see bug #257381 [1])


Markus

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=257381