[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ecf-dev] Java5 language features in JUnit tests

Hi Markus,

Markus Alexander Kuppe wrote:
Scott Lewis wrote:
  
Hi Markus,

Yes...we've been holding to JRE 1.4 compatibility for all plugins (that
can).

We can revisit this, of course.

Scott
    

Hi Scott,

I don't have a specific test case that requires JRE 1.5, though I wonder
what the benefit of having the test not exceed the bundle under test EE
in general is? The only reason I can imagine, is to debug problems on
smaller devices for which one only gets a CDC1/JRE 1.4 EE.
  

Right. 

Bottom line, I can work around JRE 1.5 and don't need anything changed
though I'd link to use JRE 1.5 features since they simplify certain things.
  

Yes, I agree there are some 1.5 features that would be useful in test code (as well as regular impl code).  I do wish that Equinox and OSGi would at least plan for move to 1.5.

I think that if there is an 'undue burden' to keep 1.4 compatibility that we should consider having test bundles that use 1.5 features.  Maybe we could even come up with/use any conventions that exist (?...perhaps in EMF?) for having both 1.5-specific test bundles alongside 1.4-specific test bundles.

Scott



Regards,
Markus

_______________________________________________
ecf-dev mailing list
ecf-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/ecf-dev