I started refactoring/remodelling the call API today and I would like to get your opinions with respect to an issue that has met some criticism from the community in the past.
The umbrella term “”Call API” seems inappropriate so I suggest we rename it to “Telephony API”. There are several reasons to support the renaming:
- “Call API” in certain contexts suggests some type of Invocation API which is clearly not the case with the ECF Call API.
- “Call” by definition limits the API capabilities solely to telephone CALLing although I can imagine the API handling other aspects within the telephony domain e.g. phone status, callcenter API, conferencing API etc. These are certainly not within the short term goals of the API, but the telephony namespace will “keep more doors open”.
- APIs similar to ours e.g. JTAPI, TAPI have traditionally carried the umbrella term “Telephony” and a design along the same lines will favor a suitable learning curve both for the users as well as for the implementers of the API.
I look forward to you dropping your thoughts on this. In case of positive feedback, I will rename the packages from “org.eclipse.ecf.*” to “org.eclipse.ecf.telephony.*”. e.g. the “org.eclipse.ecf.call” package will become the “org.eclipse.ecf.telephony.call” package.