[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[ecf-dev] JMS Provider Connection Issues (ECF Plugin)?

Hi Steve

I was hoping you could send to me the link for the JMS ECF Plug in please?

I am having issues developing a plug in to connect to a JMS provider as 
detailed below.


I am doing some plugin development and I am looking to connect to a JMS  
provider.

The ones I have been using are openJMS and ActiveMQ.

When I prototype connection code for both these using an Eclipse Java 
Scrapbook page and can connect to the JMS provider no problems.

But I seem to be hitting issues when I run the same code from within a plugin.

For use w/ ActiveMQ, I have used the following lines of code:

org.activemq.ActiveMQConnectionFactory activeMQConnectionFactory = new 
org.activemq.ActiveMQConnectionFactory(user, pwd, url);
connection = activeMQConnectionFactory.createConnection();
if (durable && clientID != null) connection.setClientID(clientID);
connection.start();

W/in the Scrapbook page this runs w/ no problems.

When running in a plugin the execution seems to hang on the following line of 
code:
org.activemq.ActiveMQConnectionFactory activeMQConnectionFactory = new 
org.activemq.ActiveMQConnectionFactory(user, pwd, url);

Worse still, I cannot see any error traces anywhere, including my Workspace  
log file /.metadata/.log

The code is being run in a separate thread.

Any indication of what might be wrong or where I can go to get more logging 
information would be much appreciated.

I am using Eclipse verision 3.1.1.

Thanks, Hong...