Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [e4-dev] Proposals


Bugzilla would be the perfect place for this. The mailing lists are best used for general discussions, such as "when do we start limiting fixes - in RC4?" :-).

Sincerely,
Oleg Besedin



From: "Stefan Mücke" <s.muecke@xxxxxxxxx>
To: <e4-dev@xxxxxxxxxxx>
Date: 07/06/2010 12:17 PM
Subject: [e4-dev] Proposals
Sent by: e4-dev-bounces@xxxxxxxxxxx





Hi e4 developers,

I have some minor proposals for the e4 code, but I don't know where to put them; opening bugs for them seems overkill to me.

Therefore I am posting them here. Could please someone pick up what is acceptable?

- PrimaryObjectSupplier should be replaced by IObjectSupplier

 Class PrimaryObjectSupplier provides no functionality, and the name
 is clumsy. I cannot see why there needs to be an abstract class instead of
 an interface. If the abstract class needs to stay, I would rename
 it to ObjectSupplier.

- Rename PrimaryObjectSupplier.get(...) to PrimaryObjectSupplier.getObjects(...)

 This improves readability of the code.

- Question: The ContextObjectSupplier.get(...) checks the 'track' parameter
 and creates a RunAndTrack when 'track' is true'. In this case, however, it
 does not compute the actual arguments for the IObjectDescriptors. Doesn't
 that mean that there should be two different methods on an object supplier?
 
 PrimaryObjectSupplier.getObjects(IObjectDescriptors ...)
 PrimaryObjectSupplier.trackObjects(IObjectDescriptors ...)

- "abstract public" should be replaced by "public abstract"

                There are a lot of classes where I found this.

- EclipseContext.removeListenersTo(Object) should be renamed
  removeListenersFor(Object).


Stefan


_______________________________________________
e4-dev mailing list
e4-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/e4-dev



Back to the top