[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [dsdp-tm-dev] FileSystem open flags

Hi Ed,

I agree, adding TCF_ prefix to avoid confusion is good idea.
I'll create a bugzilla entry for that.


-----Original Message-----
From: dsdp-tm-dev-bounces@xxxxxxxxxxx
[mailto:dsdp-tm-dev-bounces@xxxxxxxxxxx] On Behalf Of Ed Swarthout
Sent: Wednesday, May 14, 2008 10:47 AM
To: dsdp-tm-dev@xxxxxxxxxxx
Subject: [dsdp-tm-dev] FileSystem open flags

The open flags for FileSystem (as shown in "TCF Service - File
System.html") use the same names (i.e. O_CREAT) that are defined in
libc's fcntl.h.  

Unfortunately, I hadn't noticed that they are defined differently and I
used the fcntl.h values in some c-client code I wrote.
It didn't work.

Looking at the source, I see that agent/filesystem.c prefix's the open
flag definitions with TCF_ so they don't conflict.

Wouldn't it be good to add this same prefix in the java interface,
That way the language independent API can show a single name for the
open flags?

dsdp-tm-dev mailing list