Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[dsdp-tm-dev] Re: RSE Refactorings

Hi Martin,

I agree with #1, #4 and #5. It looks like #2 and #3 are being discussed
right now. One suggestion I have is that we prefix our interfaces and
classes with "RSE", e.g. IRSESubSystemConfiguration, RSESubSystemFactory,
etc. to be consistent with the other new names such as IRSESystemType.

Thanks,

Kushal Munir
Websphere Development Studio Client for iSeries
IBM Toronto Lab, 8200 Warden Ave., Markham, ON
Phone: (905) 413-3118        Tie-Line: 969-3118
Email: kmunir@xxxxxxxxxx



                                                                           
             "Oberhuber,                                                   
             Martin"                                                       
             <Martin.Oberhuber                                          To 
             @windriver.com>           "David Dykstal"                     
                                       <david_dykstal@xxxxxxxxxx>, David   
             08/11/2006 09:47          McKnight/Toronto/IBM@IBMCA          
             AM                                                         cc 
                                       Kushal Munir/Toronto/IBM@IBMCA,     
                                       "Target Management developer        
                                       discussions"                        
                                       <dsdp-tm-dev@xxxxxxxxxxx>           
                                                                   Subject 
                                       RSE Refactorings                    
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           




Hello Dave's,

I would like to perform the following refactorings:

1. Rename Extension Point
      "subsystemconfiguration" --> "subSystemConfigurations"
   Rationale: Be more in-line with Platform names

2. Rename Extension Point Elements of "subSystemConfigurations"
   <configuration
      "class"       --> "factoryClass"       (required)
      "systemClass" --> "connectorService"   (optional)
   />
   Rationale: unify naming, and allow for further extension
   with e.g. serviceClass attribute or "class" attribute
   for an actual ISubSystemConfiguration.

3. Rename Classes and Interfaces
      *SubSystemConfiguration* --> *SubSystemFactory*
   Rationale: the SubSystemFactory is essentially a factory,
   since its main task is to create ISubSystem objects. Also,
   current RSE Documentation refers to "factories" in an
   endless number of places.

4. Move extension point documentation from plugin.xml
   into the *.exsd schema

5. Replace text matches in comments
      ISystem --> IConnectorService


We can think about adding more attributes to the
"subSystemConfigurations" extension point later,
allowing for a split between SubSystemFactory and
SubSystemConfiguration if desired.

This would essentially mean adding a new type
ISubSystemConfiguration that would refer to
existing SubSystemFactories, in order to allow
better re-use of SubSystemFactories for work in
different configurations (services, connectorservices,
attributes).

Would you agree with these refactorings?

Thanks,
--
Martin Oberhuber
Target Management Project Lead, DSDP PMC Member
http://www.eclipse.org/dsdp/tm




Back to the top