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MTJ Test Specification

Mobile Tools for the Java Platform

Test Cases for System Testing

<TEST AREA>

<Test Case Name>

	ID 
	Unique Identifier (referred to in the test results)

	Version  
	Proposed | Approved | Rejected | Postponed

	Priority 
	Low | Medium | High

	Author 
	Name of the author

	Date 
	Date created/Last modified

	Test objectives
	What is the goal of this test

	Related requirements
	Related Use Case or other requirement


	Step Name
	Description
	Expected

	Precondition(s)
	
	

	Step 1  
	Action to be done
	Expected outcome

	Step 2  
	
	


	Overall outcome
	What is the end result of this test procedure

	Additional information
	Some more information, comments, etc.
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INSTALLING MTJ 

Install MTJ to Eclipse 3.2 in Win XP Pro + SP2

	ID 
	MTJ_Install_001

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Sari Salin

	Date 
	10.4.2006

	Test objectives
	To test the installation of MTJ to Eclipse 3.2 in the Windows XP Pro OS.

	Related requirements
	Use case Installation, Windows


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ not installed. Eclipse 3.2installed. OS is XP Pro + SP2
	

	Step 1
	
	

	Step 2
	
	

	Step 3
	
	

	Step 4
	
	


	Overall outcome
	MTJ is installed, MTJ-specific menu items are present

	Additional information
	


Install MTJ to Eclipse 3.2 in Linux

	ID 
	MTJ_Install_002

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Sari Salin

	Date 
	10.04.2006

	Test objectives
	To test the installation of MTJ to Eclipse 3.2 in Linux.

	Related requirements
	Use case Installation, Linux


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ not installed. Eclipse 3.2 installed. OS is Linux.
	

	Step 1
	
	

	Step 2
	
	

	Step 3
	
	

	Step 4
	
	


	Overall outcome
	MTJ is installed, MTJ-specific menu items are present

	Additional information
	


MTJ MIDP PROJECT CREATION

Create MTJ MIDP Project with default settings.
	ID 
	MTJ_MIDP_Create_Project_001

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	.To test creation of an MTJ Project with the project creation wizard by using all default settings.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
Verify that the Eclipse defaults for source and binary directories is set.  That is, Windows > Preferences > Java > Build Path > Source and output folder dialog is set to Project.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 4  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 5  
	Select the first “Configuration” listed/
	The configuration will be selected, and any other siblings will be grayed out.
Next will now be enabled.

	Step 6  
	Press Next
	The Java settings panel is displayed.
Next is enabled.  Finish is not available.

	Step 7  
	Select the “Libraries” tab.
	The libraries will be displayed.  The only listing should be the “J2ME library” container.  

	Step 8 
	Expand the “J2ME Library” entry
	There should be a pointer to the configuration selected.

	Step 9 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 10 
	Verify the default fields on the table.
	Midlet Jar Name should match the “project_name”.jar

Midlet suite Name should match “project_name” Midlet Suite

Vendor Name should match eclipse.org

Version should match 1.0.0

Profile should match MIDP-2.0

Configuration should match CLDD-1.0.

	Step 11 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 12 
	Expand the project in the Navigator.
	Verify resources created in the Java Perspective, Package Explorer.

There will be a library listed “J2ME library” which will be the container viewed earlier.

There will be a “META-INF” directory, containing a “MANIFEST.MF” file.

There should be a “project_name”.jad file.

There should be a “mtj.project” file.

If your Windows > Preferences > Java > Build Path values suggest to create a “src” file, that will be present.  Otherwise, it will not be.


	Overall outcome
	A MTJ Midlet project is created.

	Additional information
	


Create MTJ MIDP Project. Use alternate location for project.

	ID 
	MTJ_MIDP_Create_Project_002

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	To test creation of an MTJ Project verifying that the project is created in an alternate workspace location

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3 
	Uncheck “Use Default” in the project contents.
	Project Contents are now enabled for changes.

	Step 4 
	Browse to an alternate location.
	Alternate location is shown in Directory box.

	Step 5  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 6  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 7  
	Select the first “Configuration” listed.
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 8  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is not available.

	Step 9 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 10 
	Verify the default fields on the table.
	Midlet Jar Name should match the “project_name”.jar

Midlet suite Name should match “project_name” Midlet Suite

Vendor Name should match eclipse.org

Version should match 1.0.0

Profile should match MIDP-2.0

Configuration should match CLDD-1.0.

	Step 11 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 12 
	Verify the project creation in the file system.
	Using the operating system navigator, browse to the location where the project was created, and verify that it is there.


	Overall outcome
	A MTJ Midlet project is created.

	Additional information
	


Create MTJ MIDP Project. Test library tree.

	ID 
	MTJ_MIDP_Create_Project_003

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	To test library selection panel of the MTJ project creation.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 3  
	Unselect the main entry.
	All children of the main entry will be grayed out.

	Step 4 
	Expand all children of the main entry.
	All children and, subsequently children will be grayed out.

	Step 5 
	Expand and contract various parts of the tree to verify that all children remain grayed out.
	

	Step 6 
	Select the main entry.
	The main entry is selected, The top level children will be enabled, all lower level children will stay grayed out.

	Step 7 
	Select one of the top level children.
	All siblings of the top level children will be grayed out.  The children of the selected element will be enabled.

	Step 8 
	Try to select one of the grayed out children.
	Selection will not occur.

	Step 9 
	Select a child on the third level.
	All siblings will be grayed out, and immediate children will be enabled for selection.

	Step 10 
	Unselect the selected top level entry.
	All children of the top level entry will be unselected and grayed out.

	Step 11 
	Select the top level entry again.  Select a top level child.  (level 2)
	

	Step 12 
	Select entries down to the parent of “Profiles, Configurations, and Service Apis”
	Profiles and Configurations are selected and grayed out.  Service Apis is selected but not grayed out.

	Step 13 
	Select multiple services.
	Verify that multiple services can be selected.

	Step 14 
	Select a configuration.
	Verify that Next is enabled.

	Step 15 
	Unselect a configuration.
	Verify that Next is disabled.

	Step 16 
	Repeat steps above, unselecting various entries, and verify that the expected behavior occurs in a fashion similar to what is listed in the expected results above.  Since the data in the tree may not be fixed, this is unstructured testing.
	

	Step 17 
	Select some services to make sure that they show up in the next configuration.  Ultimately, when a desired configuration is selected, and Next is enabled, Press Next.
	

	Step 18  
	Select the “Libraries” tab.
	The libraries will be displayed.  Verify desired Configuration and Services are listed.

	Step 19 
	Expand the “J2ME Library” entry
	There should be a pointer to the configuration selected.

	Step 20 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 21 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 22 
	Expand the project in the Navigator.
	Verify resources created in the Java Perspective, Package Explorer.

There will be a library listed “J2ME library” which will be the container viewed earlier.

There will be a “META-INF” directory, containing a “MANIFEST.MF” file.

There should be a “project_name”.jad file.

There should be a “mtj.project” file.

If your Windows > Preferences > Java > Build Path values suggest to create a “src” file, that will be present.  Otherwise, it will not be.


	Overall outcome
	A MTJ Midlet project is created.

	Additional information
	


Create MTJ MIDP Project. Verify changed libraries are created as desired.

	ID 
	MTJ_MIDP_Create_Project_004

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	To test creation of an MTJ Project verifying that the project is created in an alternate workspace location.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 4  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 5  
	Select the first “Configuration” listed.
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 6  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is not available.

	Step 7  
	Select the “Libraries” tab.
	The libraries will be displayed.  The only listing should be the “J2ME library” container.  

	Step 8 
	Expand the “J2ME Library” entry
	There should be a pointer to the configuration selected.

	Step 9 
	Select “Access Rules” Press Edit.
	An edit dialog from the JDT is presented.

	Step 10 
	Add an access rule, such as Forbidden “*”, and press OK.  Press OK on add window.
	Access Rule has changed in Libraries window/

	Step 11 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 12 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 13 
	Expand the project in the Navigator.
	Verify that the library container contains the access rule set in the java settings panel.


	Overall outcome
	A MTJ Midlet project is created.

	Additional information
	


Create MTJ MIDP Project. Verify deleted libraries are not created.

	ID 
	MTJ_MIDP_Create_Project_005

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	.To test creation of an MTJ Project with the project creation wizard by using all default settings.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 4  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 5  
	Select the first “Configuration” listed/
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 6  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is not available.

	Step 7  
	Select the “Libraries” tab.
	The libraries will be displayed.  The only listing should be the “J2ME library” container.  

	Step 8 
	Select the “J2ME Library” entry.  Press Remove.
	The library container will be removed from the Libraries list.

	Step 9 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 10 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 11 
	Expand the project in the Navigator.
	There will be no library in the creation.  This is what the user explicitly asked for.


	Overall outcome
	A MTJ Midlet project is created, but there is no library container.

	Additional information
	This is performing what the user asked the creation to do.  We may not want a project without a library, but we have created what they requested.


Create MTJ MIDP Project. Verify that alternate src and bin locations are created.

	ID 
	MTJ_MIDP_Create_Project_006

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	.To test creation of an MTJ Project where the preferences are to have a single source and binary directories, but it is overridden during project creation.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.

Verify that the Eclipse defaults for source and binary directories is set.  That is, Windows > Preferences > Java > Build Path > Source and output folder dialog is set to Project.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 4  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 5  
	Select the first “Configuration” listed.
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 6  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is not available.

	Step 7  
	Select the “Source” tab.
	This is the default tab.

	Step 8 
	Check the entry for “Allow output folders for source folders”
	

	Step 9 
	Press Add Folder…
	JDT add folders dialog will be displayed.

	Step 10 
	Select Folder as source Folder, and enter “src”  Press OK
	

	Step 11 
	Expand the new entry, Select “Output folder: (Default output folder)” and Press Edit...”
	JDT folders dialog will be displayed

	Step 12 
	Select “Specific output folder…” and enter bin in the box.  Press OK
	Output Folder will now show project_name/bin

	Step 13 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 14 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 15 
	Switch to the resource view.
	Verify that the project has a bin and a src directory.


	Overall outcome
	A MTJ Midlet project is created with source and binary directories.

	Additional information
	


Create MTJ MIDP Project. Verify that alternate src and bin locations are created if set in the Preferences.

	ID 
	MTJ_MIDP_Create_Project_007

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	.To test creation of an MTJ Project where the preferences are to have separate source and binary directories.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.

Verify that the Eclipse defaults for source and binary directories is set.  That is, Windows > Preferences > Java > Build Path > Source and output folder dialog is set to Folders, and Source folder name is “src’” out folder name is “bin.”
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 4  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 5  
	Select the first “Configuration” listed.
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 6  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is not available.

	Step 7 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 8 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 9 
	Switch to the resource view.
	Verify that the project has a bin and a src directory.


	Overall outcome
	A MTJ Midlet project is created with source and binary directories.

	Additional information
	


Create MTJ MIDP Project. Modify Midlet Suite values.

	ID 
	MTJ_MIDP_Create_Project_008

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	.To test creation of an MTJ Project where the Midlet suite values are changed.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 4  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 5  
	Select the first “Configuration” listed.
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 6  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is not available.

	Step 7 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 8 
	Change all values in the Required Data section.  Write down your values for later comparison.
	

	Step 9 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 10 
	Select the project_name.jad file using Context menu, Open with > Text Editor.
	Verify the recorded values are set.  Relationships between the panel names and the JAD names should be obvious.


	Overall outcome
	A MTJ Midlet project is created.

	Additional information
	


Create MTJ MIDP Project. Back Button.

	ID 
	MTJ_MIDP_Create_Project_009

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	.To test creation of an MTJ Project making sure values are refreshed when the user goes back in the wizard.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
	

	Step 1  
	Select File > New > Project > MTJ > MTJ Midlet Project
	MTJ Project creation wizard opens

	Step 2  
	Enter  the project name
	Project name is accepted

	Step 3  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 4  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 5  
	Select the first “Configuration” listed.
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 6  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is not available.

	Step 7 
	Press Next
	The Midlet Suite Panel should be displayed.  

Next and Finish are now enabled.

	Step 8 
	Press Back, Back, Back.
	Project creation page is displayed.

	Step 9 
	Change the project name.
	

	Step 10 
	Press Next, Next, Next.
	Verify that the Required data is updated with the new names.

	Step 11 
	Press Back, Back.
	Library Selection Panel is displayed.

	Step 12 
	Change the entire configuration.
	

	Step 13 
	Press Next.
	Verify that the container values have changed.

	Step 14 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.


	Overall outcome
	A MTJ Midlet project is created.

	Additional information
	


Create MTJ Personal Profile Project. Verify mtj.project file.

	ID 
	MTJ_Create_Project_001

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Kevin Horowitz

	Date 
	2 May 2006

	Test objectives
	.To test creation of an MTJ Project with the project creation wizard by using all default settings.

	Related requirements
	Use case Create Project


	Step Name
	Description
	Expected

	Precondition(s)
	You must have a SDK that is available in the MTJ environment installed in the expected location on your system.
	

	Step 15  
	Select File > New > Project > MTJ > MTJ Project
	MTJ Project creation wizard opens

	Step 16  
	Enter  the project name
	Project name is accepted

	Step 17  
	Press Next
	Device and Libraries panel is displayed.  Next and Finish are not available.

	Step 18  
	Select the first child of each entry and expand the tree until Profile, Configurations, and Services are displayed
	The current selection will be chosen.  All siblings in the tree will be grayed out, all children in the tree will be enabled for selection (no longer gray).  When you select the parent of “Profiles, Configurations, and Services”, they will also be selected.  Profiles, and Configurations will be grayed out.  The Profile will be selected and grayed out.

	Step 19  
	Select the first “Configuration” listed.
	The configuration will be selected, and any other siblings will be grayed out.

Next will now be enabled.

	Step 20  
	Press Next
	The Java settings panel is displayed.

Next is enabled.  Finish is enabled.

	Step 21  
	Select the “Libraries” tab.
	The libraries will be displayed.  The only listing should be the “J2ME library” container.  

	Step 22 
	Expand the “J2ME Library” entry
	There should be a pointer to the configuration selected.

	Step 23 
	Press Finish
	A Progress Information dialog may show.

The project will be created in the navigator.

	Step 24 
	Expand the project in the Navigator.
	Verify resources created in the Java Perspective, Package Explorer.

There will be a library listed “J2ME library” which will be the container viewed earlier.

There will be a “META-INF” directory, containing a “MANIFEST.MF” file.

There should not be a “project_name”.jad file.

There should be a “mtj.project” file.

If your Windows > Preferences > Java > Build Path values suggest to create a “src” file, that will be present.  Otherwise, it will not be.

	Step 25 
	Edit the mtj.project file exists.
	The file should have a structure similar to:

<….Project>
<defaultTargetDevice>

<runtimePlatform>

  <deviceProfiles>

  </deviceProfiles>

  <deviceConfigurations>

  </deviceConfigurations>

</runtimePlatform>

</defaultTargetDevice>

</….Project>


	Overall outcome
	A MTJ project is created.

	Additional information
	


MTJ Security Manager

Configure Security Manager Plug-ins

	ID 
	MTJ_Security_Manager_001

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Rodrigo Pastrana

	Date 
	4/24/06

	Test objectives
	To test configuration of an installed Security Manager Plug-in.

	Related requirements
	


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ installed. A Security Manager Plug-in (SMP) is installed. The corresponding tooling for the Security Manager Plug-in is installed.
	

	Step 1
	Select Window -> Preferences… Then expand the “MTJ Preferences” option, and choose Security Management.
	The MTJ Security Management Preferences page is displayed.

	Step 2
	Select (highlight) the target plug-in from the list. Click the “Edit…” button.
	The “Security Management  Configuration”  dialog is displayed.

	Step 3
	In the “Tool Location” field, specify the location of the “home” directory of the Security Manager tool. Click the “OK” button.
	The “Security Management  Configuration”   dialog is dismissed. The “Tool location” field contents are reflected in the Security management preferences table.

	Step 3 (Alternate)
	Click the “Search…” button. Find the “home” directory of the Security Manager Tool. Click “OK”. On the Security Management Configuration dialog, Click “OK”
	The “Security Management  Configuration”  dialog is dismissed. The “Tool location” field contents are reflected in the Security management preferences table.

	Step 4
	Click on the check-box that corresponds to the target Plug-in.
	The target Plug-in is activated when the check box is set, and de-activated when the check-box is not set.

	Step 5
	Accept the configuration changes by clicking on the “OK” button.
	All configuration changes are stored, and the Security Management Preferences page is dismissed.


	Overall outcome
	The target Security Manager Plug-in is configured.

	Additional information
	Plug-in Org.eclipse.mtj.extension.smgmt  supports SUN’s J2RE 1.4.2 keytool.exe

Plug-in org.eclipse.mtj.extension.smgmt.IBM supports IBM’s JAVA 5.0 JRE keytool.exe

Plug-in Org.eclipse.mtj.extension.smgmt..j9 supports IBM’s j9 ive2.2  keytool.exe


Create new keystore

	ID 
	MTJ_Security_Manager_002

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Rodrigo Pastrana

	Date 
	4/24/06

	Test objectives
	To test the Security Manager Plug-in feature “create new keystore”.

	Related requirements
	


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ installed. A Security Manager Plug-in (SMP) is installed. The corresponding tooling for the Security Manager Plug-in is installed. The SMP is configured correctly.
	

	Step 1
	Select the “Manage MTJ application Security” option from the “MTJ menu”, or select the [image: image1.png]


 icon from the toolbar.
	The “Security Management for MTJ Applications” dialog is displayed.

	Step 2
	Select the “Key Management” tab.
	The Key Management section is displayed.

	Step 3
	Select the target SMP from the “Select Security Manager” drop-down list. 
	The selected SMP is set as the target SMP.

	Step 4
	Select the “Create a New Key Pair” button. In the “New Keystore” dialog, specify the desired location, and name of the new keystore. Select the “Save” button.
	The location, and file name specified in the “New Keystore” dialog is used as the target file name of the new keystore. The “Enter Password” dialog is displayed. 

	Step 5
	Enter the desired password for the new keystore in the two fields provided. Select the “OK” button.
	The passwords are restricted to be no less than 6 characters long. The “Enter Password” dialog is dismissed; the “New Key Pair” dialog is displayed.

	Step 6
	Populate the “New Key Pair” dialog fields with the desired key pair alias, common name, organizational name, locality name, state name, and country. Select the “Create” button.
	The Key pair is created and added to the new keystore. Succes/failure notice is displayed.


	Overall outcome
	New Keystore is created and populated with a new keypair.

	Additional information
	


Open keystore

	ID 
	MTJ_Security_Manager_003

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Rodrigo Pastrana

	Date 
	4/24/06

	Test objectives
	To test the Security Manager Plug-in feature “open keystore”.

	Related requirements
	


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ installed. A Security Manager Plug-in (SMP) is installed. The corresponding tooling for the Security Manager Plug-in is installed. The SMP is configured correctly. The target keystore is compatible with the target SMP.
	

	Step 1
	Select the “Manage MTJ application Security” option from the “MTJ menu”, or select the [image: image2.png]


 icon from the toolbar.
	The “Security Management for MTJ Applications” dialog is displayed.

	Step 2
	Select the “Key Management” tab.
	The Key Management section is displayed.

	Step 3
	Select the target SMP from the “Select Security Manager” drop-down list. 
	The selected SMP is set as the target SMP.

	Step 4
	Select the “Open” button in the “Key Store” section. 
	The “Open Keystore” dialog is displayed. 

	Step 5
	Select the target keystore from the “Open Keystore” dialog. Select the “Open” button.
	The “Open Keystore” dialog is dismissed. The “Enter Password” dialog is displayed.

	Step 6
	Enter the correct keystore password. Select the “OK” button.
	Failure/Success notification is displayed. If successful, the keystore location is displayed, and the contents of the file are displayed in the “Key Aliases:” field.


	Overall outcome
	The target keystore is opened and the contents are displayed.

	Additional information
	


Create new Key Pair

	ID 
	MTJ_Security_Manager_004

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Rodrigo Pastrana

	Date 
	4/24/06

	Test objectives
	To test the Security Manager Plug-in feature “Create new Key Pair”.

	Related requirements
	Open keystore


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ installed. A Security Manager Plug-in (SMP) is installed. The corresponding tooling for the Security Manager Plug-in is installed. The SMP is configured correctly. The target keystore is opened.
	

	Step 1
	Select the “Manage MTJ application Security” option from the “MTJ menu”, or select the [image: image3.png]


 icon from the toolbar. Open the target keystore (MTJ_Security_Manager_003)
	The “Security Management for MTJ Applications” dialog is displayed. If successful, the keystore location is displayed, and the contents of the file are displayed in the “Key Aliases:” field.

	Step 2
	Select the “Create a New Key Pair” button.
	The “New Key Pair” dialog is displayed.

	Step 3
	Populate the  “New Key Pair” dialog fields. Enter the desired alias, common name, organizational unit, organizational name, locality name, state name, and country. Select the “Create” button.
	Failure/Success notification is displayed. If successful, the new key pair alias is displayed in the “Key Aliases:” field, alongside the rest of the keystore’s contents.


	Overall outcome
	New keypair is created, and added to the target keystore.

	Additional information
	


MTJ Signing provider

Configure Signing Provider Plug-ins

	ID 
	MTJ_Signing_Provider_001

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Rodrigo Pastrana

	Date 
	4/24/06

	Test objectives
	To test configuration of an installed Siging provider Plug-in.

	Related requirements
	


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ installed. A Signing Provider Plug-in (SPP) is installed. The corresponding tooling for the SPP is installed.
	

	Step 1
	Select Window -> Preferences… Then expand the “MTJ Preferences” option, and choose Signing Provider.
	The MTJ Signing Provider Preferences page is displayed.

	Step 2
	Select (highlight) the target plug-in from the list. Click the “Edit…” button.
	The “Signing Provider Configuration” dialog is displayed.

	Step 3
	In the “Tool Location” field, specify the location of the “home” directory of the Signing Provider tool. Click the “OK” button.
	The “Signing Provider Configuration” dialog is dismissed. The “Tool location” field contents are reflected in the Signing Provider  preferences table.

	Step 3 (Alternate)
	Click the “Search…” button. Find the “home” directory of the Signing Provider Tool. Click “OK”. On the Signing Provider Configuration diaolog, Click “OK”
	The “Signing Provider Configuration” dialog is dismissed. The “Tool location” field contents are reflected in the Signing Provider preferences table.

	Step 4
	Click on the check-box that corresponds to the target Plug-in.
	The target Plug-in is activated when the check box is set, and de-activated when the check-box is not set.

	Step 5
	Accept the configuration changes by clicking on the “OK” button.
	All configuration changes are stored, and the Signing Provider Preferences page is dismissed.


	Overall outcome
	The target Signing Provider Plug-in is configured.

	Additional information
	Plug-in orgl.eclipse.mtj.extension.sp supports SUN’s WTK 2.2 JadTool.jar

Plug-in orgl.eclipse.mtj.extension.sp supports IBM’s J9 IVE 2.2 jadsigner.exe


Sign an MTJ application

	ID 
	MTJ_Signing_Provider_002

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Rodrigo Pastrana

	Date 
	4/24/06

	Test objectives
	To test the signing of an MTJ application.

	Related requirements
	MTJ_Signing_Provider_001


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ installed. A Signing Provider Plug-in (SPP) is installed. The corresponding tooling for the SPP is installed. The SPP is correctly configured. A Security Manager Plug-in (SMP) is installed, and configured, and corresponding tool is installed.
	

	Step 1
	Select the “Manage MTJ application Security” option from the “MTJ menu”, or select the [image: image4.png]


 icon from the toolbar. Open the target keystore (MTJ_Security_Manager_003)
	The “Security Management for MTJ Applications” dialog is displayed. The keystore location is displayed, and the contents of the file are displayed in the “Key Aliases:” field.

	Step 2
	Select the target MTJ application to be signed. Select the “Browse…” button. Select the target project from the eligible project list. Select the “OK” button.
	The “Project Selection” dialog is displayed.  The selected project is displayed in the “MTJ Project” field. 

	Step 3
	Select the “Signing Provider” tab.
	The “Signing Provider” section is displayed.

	Step 4
	Select the target SPP from the “Select Signing Provider” drop-sown list. Select the “Key Management” tab
	The target SPP is selected. The “Key Management section is displayed”

	Step 5
	Select  (highlight) the target “Key pair” from the “Key Aliases” field. 
	The chosen key alias’ data is displayed in the “key data” field. The Sign/Unsign buttons are enabled or disabled depending on the current signing condition of the application

	Step 6
	If the application is not currently signed (the “Sign” button is enabled), select the “Sign” button.
	Success/failure notifications are displayed. If successful, the appliction is signed.  The “Sign” button is disabled. The “Unsign” button is enabled.


	Overall outcome
	The target MTJ application is signed.

	Additional information
	Currently, the Signing Provider feature supports only MIDP 2.0 applications.


Unsign an MTJ application

	ID 
	MTJ_Signing_Provider_003

	Version  
	Proposed

	Priority 
	Medium

	Author 
	Rodrigo Pastrana

	Date 
	4/24/06

	Test objectives
	To test the unsigning of an MTJ application.

	Related requirements
	MTJ_Signing_Provider_001, MTJ_Signing_Provider_002


	Step Name
	Description
	Expected

	Precondition(s)
	MTJ installed. A Signing Provider Plug-in (SPP) is installed. The corresponding tooling for the SPP is installed. The SPP is correctly configured. A Security Manager Plug-in (SMP) is installed, and configured, and corresponding tool is installed. The target application is currently signed.
	

	Step 1
	Select the “Manage MTJ application Security” option from the “MTJ menu”, or select the [image: image5.png]


 icon from the toolbar. Open the target keystore (MTJ_Security_Manager_003). 
	The “Security Management for MTJ Applications” dialog is displayed. The keystore location is displayed, and the contents of the file are displayed in the “Key Aliases:” field.

	Step 2
	Select the target MTJ application to be signed. Select the “Browse…” button. Select the target project from the eligible project list. Select the “OK” button.
	The “Project Selection” dialog is displayed.  The selected project is displayed in the “MTJ Project” field. 

	Step 3
	Select the target SPP (MTJ_Signing_Provider_002 steps 2 and 3).
	A target SPP is selected. If the target application is signed, the “Unsign” button is enabled.

	Step 4
	Select the “Unsign” button.
	Success/failure notifications are displayed. If successful the target MTJ application is unsigned.


	Overall outcome
	The target MTJ application is unsigned.

	Additional information
	Currently, the Signing Provider feature supports only MIDP 2.0 applications.


