Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[dali-dev] "packaging" fold-in and orm rename

I've done some base refactoring in my codebase and, while folding my current packaging code into our core plugin, have come up with the following rename choices:

ecore and genmodel:
rename "dali" e-package to "orm"

emf classes:
rename DaliFactory and DaliSwitch to OrmFactory and OrmSwitch This is done automatically as a result of the above e-package rename.

emf packages:
org.eclipse.dali.core -> org.eclipse.dali.orm (org.eclipse.dali.core will still exist, but won't contain EMF-specific classes for the orm model) This also corresponds to j2ee naming conventions. org.eclipse.dali.core.impl -> org.eclipse.dali.orm.internal.impl The internal part is consistent with J2EE as well. J2EE exports their internal packages so that others *can* use them, but also with the proviso that they may change.
org.eclipse.dali.core.util -> org.eclipse.dali.orm.internal.util

org.eclipse.dali.edit -> org.eclipse.dali.orm.provider I also support folding the edit plugin into our core plugin, similar to how J2EE does it as well.



Any thoughts, dissent, or debate on the issue?

- Paul



Back to the top