[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] M7



On Tue, May 8, 2012 at 10:02 PM, Marc-Andre Laperle <malaperle@xxxxxxxxxxxxx> wrote:
On 12-05-08 11:56 PM, Doug Schaefer wrote:
Hey gang, is it just me or does M7 seem like it has a lot of issues. Almost all my smoke tests Âsee some sort of issue, mostly in build/CModel. The worst being the internal builder, which is used by the MinGW toolchain on Windows, doesn't seem to be picking up resource changes and thus never builds.
It looks like this happens when "Build automatically" is used, I don't see the problem when it's turned off. If you turn that off does it work OK for you?

I'm also seeing the refresh not being done on the initial project build at project creation time and thus not finding any binaries breaking the initial debug.

This might be related to the recent changes to RefreshScopeManager (per configuration refresh, bug 374442, 375859 ). It seems obvious to me that this one wasn't reviewed or tested enough before getting committed, I have found many problems with the limited testing I did. I just think we should test more in general.

Should we revert these commits until the problems are addressed?Â


Marc-Andre

-sergeyÂ

I'm wondering if it's just me as I consider these to be fundamental test cases and if our community is going to run into them, I'd find that pretty embarrassing. Is it just me?

Doug.


_______________________________________________
cdt-dev mailing list
cdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cdt-dev



_______________________________________________
cdt-dev mailing list
cdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cdt-dev