[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] Problem with tycho 0.14 and cross/org.eclipse.launch.remote

Hey Jeff, we have run into this with other feature/plugins with the same
id. I resolved it by using a different groupId, i.e.
org.eclipse.cdt.feature. Not sure how this has been working until now with
the remote feature/plugin (this problem existed with 0.13 I believe).

Doug.

On 12-04-04 5:10 PM, "Jeff Johnston" <jjohnstn@xxxxxxxxxx> wrote:

>I am working on building CDT under Fedora using tycho 0.14 (the minimum
>version of tycho that Fedora supplies - new for F17).
>
>I ran into an issue with cross/org.eclipse.launch.remote plugin and
>feature.  They both have the same artifactId/groupId which tycho 0.14
>prohibits.  As well, tycho 0.14 forces the artifactId to match the
>feature id so simply changing the artifactId for the feature pom.xml
>does not solve the problem.
>
>In LinuxTools we fixed this for features that had this issue by renaming
>the feature and artifactId append ".feature".  Unfortunately, we did
>this between SR1 and SR2 and renaming features isn't a great thing to do
>with regards to updating.  To preserve the update path, we had to add
>info in the p2.inf file of the renamed features so that it would update
>for the old feature group ids.
>
>I don't know if this would be considered an issue for CDT Juno (i.e. you
>might not expect users to ever try and update the launch remote feature
>on its own).
>
>Unless someone has a better solution, now might be a good time to do a
>rename before an official Juno release is out and you decide to use
>tycho 0.14 for SR1 or SR2.
>
>Thoughts?
>
>-- Jeff J.
>_______________________________________________
>cdt-dev mailing list
>cdt-dev@xxxxxxxxxxx
>https://dev.eclipse.org/mailman/listinfo/cdt-dev