[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] CDT and Java 1.6

Considering that Java 6 will crash in some cases while JIT compiling some CDT code, I prefer not to go to Java 6.

 

https://bugs.eclipse.org/bugs/show_bug.cgi?id=360855
https://bugs.eclipse.org/bugs/show_bug.cgi?id=357757

 

Alternatively the CDT code can easily be refactored to prevent the ( known) JVM  crash.

 

My two cents.

Dobrin

 

 

From: cdt-dev-bounces@xxxxxxxxxxx [mailto:cdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Sergey Prigogin
Sent: Monday, October 17, 2011 7:47 PM
To: CDT General developers list.
Subject: Re: [cdt-dev] CDT and Java 1.6

 

CDT now requires Java 1.6.

 

-sergey

On Tue, Oct 4, 2011 at 10:26 AM, Marc Khouzam <marc.khouzam@xxxxxxxxxxxx> wrote:

I've never felt a very strong urge to go to 1.6, but I personally don't mind.

String.isEmpty() and @Override for interface would be nice.

 


From: cdt-dev-bounces@xxxxxxxxxxx [mailto:cdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Sergey Prigogin
Sent: Monday, October 03, 2011 7:50 PM
To: CDT General developers list.
Subject: [cdt-dev] CDT and Java 1.6

Are there any objections against introducing dependency on Java 1.6 in CDT 9? The reasons for introducing the dependency are: String.isEmpty() method, Deque insterface, @Override annotations for implemented interface methods.

 

-sergey


_______________________________________________
cdt-dev mailing list
cdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cdt-dev