[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] CDT 8 builds now requires Eclipse 3.7

Actually, the latest HEAD (from just now) still builds with 3.6...
________________________________________
From: cdt-dev-bounces@xxxxxxxxxxx [cdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Doug Schaefer [cdtdoug@xxxxxxxxx]
Sent: November 4, 2010 8:48 PM
To: CDT General developers list.
Subject: Re: [cdt-dev] CDT 8 builds now requires Eclipse 3.7

Hmm, how'd that happen? I don't remember anyone pulling the trigger.

On Thu, Nov 4, 2010 at 7:18 PM, Marc-Andre Laperle
<malaperle@xxxxxxxxxxxxx> wrote:
> FYI,
>
> CDT 8 builds require Eclipse 3.7 as of build I201011021205 (hudon #399). If
> I install >= #399 I get many exceptions like:
>
> java.lang.NoSuchMethodError:
> org.osgi.framework.Version.compareTo(Lorg/osgi/framework/Version;)
> at
> org.eclipse.cdt.managedbuilder.core.ManagedBuildManager.isVersionCompatible(ManagedBuildManager.java:1982)
> at
> org.eclipse.cdt.managedbuilder.core.ManagedBuildManager.loadExtensionsSynchronized(ManagedBuildManager.java:2178)
> ...
>
> I know it was planned to require 3.7, but I wanted to let everyone know that
> it is required now if you install a recent build.
>
> Marc-Andre
> _______________________________________________
> cdt-dev mailing list
> cdt-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/cdt-dev
>
_______________________________________________
cdt-dev mailing list
cdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cdt-dev