[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] [DSF] API tooling errors

Sorry, that's my fault.
I removed InstructionPointerImageProvider as it is obsolete now, 
but did not notice that it is public API.
Interestingly, API tooling does not show an error for me. 

I'll restore the file.

Toni

> -----Original Message-----
> From: cdt-dev-bounces@xxxxxxxxxxx 
> [mailto:cdt-dev-bounces@xxxxxxxxxxx] On Behalf Of Vladimir Prus
> Sent: Thursday, September 30, 2010 2:21 PM
> To: CDT General developers list.
> Subject: [cdt-dev] [DSF] API tooling errors
> 
> 
> Hi,
> 
> I've tried to enable API tooling for DSF (since last time 
> I've submitted a 
> patch I was asked about that), and got two errors:
> 
> Description	Resource	Path	Location	Type
> The major version should be incremented in version 
> 2.2.0.qualifier, since API 
> breakage occurred since version 2.1.0.201006141710	MANIFEST.MF	
> /org.eclipse.cdt.dsf.ui/META-INF	line 6	Version 
> Numbering Problem
> 
> Description	Resource	Path	Location	Type
> The type 
> org.eclipse.cdt.dsf.debug.ui.sourcelookup.InstructionPointerIm
> ageProvider has 
> been removed from org.eclipse.cdt.dsf.ui_2.2.0	MANIFEST.MF	
> /org.eclipse.cdt.dsf.ui/META-INF	line 1	Compatibility Problem
> 
> I have what I believe a final 7.0 release selected as api 
> baselines, and I have 
> an up-to-date checkout of CDT.
> 
> What do these errors mean, and how do I fix them?
> 
> - Volodya
> 
> _______________________________________________
> cdt-dev mailing list
> cdt-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/cdt-dev
>