Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [cdt-dev] Renaming "DSF Disassembly"

We are actively working on retrofitting the DSF Disassemby view to work with CDI, thus making the non-DSF one obsolete. If we are successful, this will address your concern, since there will only be one view.

John

At 04:16 PM 1/13/2010, Mehregani, Navid wrote:
Content-Language: en-US
Content-Type: multipart/alternative;
         boundary="_000_496565EC904933469F292DDA3F1663E602AA31150Cdlee06enttico_"

Hello,
 
I’ve used activities to hide CDI’s Disassembly view.  Our product is only shipped with DSF Disassembly view.  However, our users don’t know or care about DSF.  I’m sure most CDT users (not developers) really know what DSF/CDI is.
At first I thought about hiding the DSF Disassembly view via activities and redefining it with a new name, but that doesn’t work since DisassemblyView class is in an internal package that’s not exported.  I assume the community wouldn’t want to export this package?  I obviously don’t want to duplicate the code in DisassemblyView and DisassemblyPart. 
 
Does anyone else have this problem? Does it make sense to rename DSF Disassembly to something that would be a bit more meaningful to CDT users? (similar to Memory and Memory Browser views). 
 
Thanks for your help,
 
- Navid
_______________________________________________
cdt-dev mailing list
cdt-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/cdt-dev

Back to the top