[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [cdt-dev] Eclipse 2.1 vs 2.0

> -----Original Message-----
> From: Alain Magloire [mailto:alain@xxxxxxx]
> Sent: Monday, March 03, 2003 12:41 PM
> To: cdt-dev@xxxxxxxxxxx
> Subject: [cdt-dev] Eclipse 2.1 vs 2.0
> 
> 
> 
> Folks here are complaining that it is more and more difficult 
> to be compatible
> with the two Eclipse platforms.  The semantics, and 
> signatures are changing.
> 
> What is the clear policy on the subject, now it is ambiguous.
> Sebastien's meeting notes did say clearly 2.0.x, but folks
> are filing PR "not working with M4, M5, RC1 etc .."
> According to the Eclipse web site the 2.1 release is April.
> 
> Being stuck between "work on 2.0.x but should work on 2.1.x" 
> is a burden
> as we can not take full advantage of any platform.
> A good #ifdef
> #if defined(ECLIPSE_2.0.x)
> #endif
> 

I agree with Alain, it is becoming increasingly frustrating for users and
developers.

The last release (1.0.1) of the CDT was designated as being Eclipse 2.0.x
compliant.

We have said that we would support the last released version of Eclipse.
Eclipse is now building release candidates for 2.1.

It makes sense that as we are working toward the next release of the CDT (on
the HEAD branch of CVS) that we support the platform that we have said we
will support for that platform (namely Eclipse 2.1).

I would have to say that we are close enough to the next release and Eclipse
is close enough to their next release, that we need to start developing and
building against Eclipse 2.1.


-Judy


> _______________________________________________
> cdt-dev mailing list
> cdt-dev@xxxxxxxxxxx
> http://dev.eclipse.org/mailman/listinfo/cdt-dev
>