[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[buckminster-dev] Re: Compilation errors in org.eclipse.buckminster.svn

Hi Carlos,
yes, we are well aware of this problem. Subclipse decided to distribute their plug-ins as jar files even though they in turn contains jars. The OSGi runtime is fine with that. However, the Eclipse compiler is not, hence the compilation errors.


You have two choices to get around this.
1. Use subclipse 1.0.5 from the update site http://subclipse.tigris.org/update_1.0.x and remember to uncheck the "Display only latest version". This version is not distributed as a jar.


2. Continue with 1.2.0 and import the plug-in into your workspace using "Import" -> "Existing projects into workspace". This will make the error go away. You'll now run into another problem when you use self hosting. To get around that you must modify the launch configuration to exclude the imported plug-in and instead use the one from your runtime.

I'm sorry for the inconvenience. We've tried to make the Subclipse team change their distribution but so far they haven't. They will have a more fine grained distribution in the future and that will make the problem disappear anyway.

Regards,
Thomas Hallgren


Carlos Sanchez wrote:
I have org.eclipse.buckminster.svn in Eclipse 3.3M6 (in M5 was the same
problem) and none of the org.tigris.subversion.svnclientadapter.*
imports can be resolved.

I have subclipse 1.2.0 from the update site
http://subclipse.tigris.org/update_1.2.x and everything looks fine in
the bundle.

Has anyone else experienced this problem?