[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [aspectj-users] Before I forget

The exception would appear to occur for an ITD on a generic type where
the ITD is sharing a type variable with the target.
It is attempting to identify the actual occurrence of parameterization
in the target type so it knows what the type variable should bind to.

If the ITD is

List<Z> SomeInterface<Z>.foo;

and the generic declaration is

class Clazz implements SomeInterface<String> {
}

then it is looking for SomeInterface in the Clazz hierarchy - so it
knows Z is String for the new member in Clazz.  For some reason it
doesn't find SomeInterface in the Clazz hierarchy (is it perhaps being
declare'd parents'd in? that would be pretty advanced)

The exception is thrown with some text to give us more information, I
wonder why you don't see it...

Andy

2009/10/13 Dave Whittaker <dave@xxxxxxxxxx>:
> Just had this pop up in Eclipse while doing some refactoring today:
> org.aspectj.weaver.BCException
> at
> org.aspectj.weaver.ResolvedType.fillInAnyTypeParameters(ResolvedType.java:1436)
> at
> org.aspectj.weaver.ResolvedType.addInterTypeMunger(ResolvedType.java:1476)
> at
> org.aspectj.ajdt.internal.compiler.lookup.AjLookupEnvironment.weaveInterTypeDeclarations(AjLookupEnvironment.java:687)
> at
> org.aspectj.ajdt.internal.compiler.lookup.AjLookupEnvironment.weaveInterTypeDeclarations(AjLookupEnvironment.java:559)
> at org.as ...
> /sunpkcs11.jar:/Applications/Eclipse/Eclipse-3.5/Eclipse.app/Contents/MacOS/../../../plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar:
> Version: 2.0.1.e35x-20091001-1600
> I don't expect that it will be a continual problem, but thought you'd like
> to take a look into the cause.
> I've also noticed that incremental compilation often seems to not update the
> markers in the IDE until I've done a full rebuild.  Several times I've
> deployed code from a project with no markers only to have it fail with an
> exception when running that is equivalent to what the build error was.
>  After a clean/rebuild the appropriate error shows up in Eclipse.  Any
> recommended steps for debugging that?
>
>
> _______________________________________________
> aspectj-users mailing list
> aspectj-users@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/aspectj-users
>
>