[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [aspectj-users] RuntimeException: cannot register non aspect?

Hi!
perfect, it works as expected! It takes an additional export of the
AspectJ-powered bundle (after the Eclipse product is exported) and it
works like a charm!

Thank you very much for pointing this out! :-)

Daniel

On Mon, Aug 24, 2009 at 5:55 AM, Andrew Eisenberg<andrew@xxxxxxxxxxxx> wrote:
> Daniel,
>
> Binary cycles are supported in the latest 3.5 dev release.  If you are
> using the 3.5 stream of AJDT, please update to the latest dev build.
>
> On Fri, Aug 21, 2009 at 12:53 AM, Daniel<daniel.rampanelli@xxxxxxxxx> wrote:
>> I see, now it's all getting more clear.
>>
>> I have now noticed the options to export plugins and even Eclipse
>> products with AspectJ support. The only problem is that my target
>> platform contains some binary cycles and it seems that these wizards
>> doesn't support them (they seem like the wizards in 3.4).
>>
>> Well, it seems to me that it's time to ask for this enhancements ... :-)
>>
>> Thank you much for the help!
>> Daniel
>>
>> On Thu, Aug 20, 2009 at 5:54 PM, Andrew Eisenberg<andrew@xxxxxxxxxxxx> wrote:
>>> It appears that you are not using the correct export wizard.  You
>>> should be running "Deployable plugins and fragments with AspectJ
>>> support".
>>>
>>> On Thu, Aug 20, 2009 at 5:48 AM, Daniel<daniel.rampanelli@xxxxxxxxx> wrote:
>>>> I just noticed that the export wizard includes only the *.aj files in
>>>> the bundle and the class files under the directory /bin/... , but the
>>>> class files should be /... !
>>>>
>>>> Maybe this is the source of the problem ... the class are not in the
>>>> right place! That means that the weaver is unable to determine if the
>>>> type is an aspect, because it has no type information at all.
>>>>
>>>> Does anybody know how to correctly include the class files in the
>>>> bundle at the right place?
>>>>
>>>> Daniel
>>>>
>>>> On Thu, Aug 20, 2009 at 9:00 AM, Daniel<daniel.rampanelli@xxxxxxxxx> wrote:
>>>>> Hi!
>>>>>
>>>>> yes I'm cure sure that the supplement headers are set, unless it
>>>>> wouldn't work when launched in Eclipse.
>>>>>
>>>>> Or maybe the bundles have to be specified in another way if we are
>>>>> running it as a binary? I hope not because it would be quite
>>>>> confusing.
>>>>>
>>>>> Daniel
>>>>>
>>>>> On Wed, Aug 19, 2009 at 6:20 PM, Andrew Eisenberg<andrew@xxxxxxxxxxxx> wrote:
>>>>>> Not sure what the problem could be here.  Have you set your
>>>>>> MANIFEST.MF with the correct supplement headers?
>>>>>>
>>>>>> On Wed, Aug 19, 2009 at 7:30 AM, Daniel<daniel.rampanelli@xxxxxxxxx> wrote:
>>>>>>> Hi to everyone,
>>>>>>>
>>>>>>> I'm working on a Eclipse RCP application and I obviously am using
>>>>>>> aspects in my software. So, I setup a special bundle containing the
>>>>>>> aspects and the aop.xml (in the META-INF folder). The weaving is
>>>>>>> performed by the functionality provided by Equinox Aspects bundle.
>>>>>>>
>>>>>>> That means I have,
>>>>>>>
>>>>>>> client bundle : containing classes that are to be woven
>>>>>>> aspect bundle : containing aspects and aop.xml
>>>>>>>
>>>>>>> As long as I'm using Eclipse to start and run my application,
>>>>>>> everything is fine. But today I tried to export the software and I
>>>>>>> discovered this exception stack trace in the Console.
>>>>>>>
>>>>>>> 8/19/09 3:58:50 PM [0x0-0xd80d8].org.eclipse.eclipse[2546]
>>>>>>> java.lang.RuntimeException: Cannot register non aspect:
>>>>>>> client$aspects$ThreadSafeExecutor , client.aspects.ThreadSafeExecutor
>>>>>>> 8/19/09 3:58:50 PM [0x0-0xd80d8].org.eclipse.eclipse[2546]  at
>>>>>>> org.aspectj.weaver.bcel.BcelWeaver.addLibraryAspect(BcelWeaver.java:219)
>>>>>>> 8/19/09 3:58:50 PM [0x0-0xd80d8].org.eclipse.eclipse[2546]  at
>>>>>>> org.aspectj.weaver.loadtime.ClassLoaderWeavingAdaptor.registerAspects(ClassLoaderWeavingAdaptor.java:432)
>>>>>>> 8/19/09 3:58:50 PM [0x0-0xd80d8].org.eclipse.eclipse[2546]  at
>>>>>>> org.aspectj.weaver.loadtime.ClassLoaderWeavingAdaptor.registerDefinitions(ClassLoaderWeavingAdaptor.java:267)
>>>>>>> [...]
>>>>>>>
>>>>>>> The software is being deployed with all the needed bundles and
>>>>>>> dependencies and I also checked that the aspects are being included in
>>>>>>> the binary build of the bundle.
>>>>>>>
>>>>>>> Has anybody a clue about my problem?
>>>>>>>
>>>>>>> Daniel
>>>>>>> _______________________________________________
>>>>>>> aspectj-users mailing list
>>>>>>> aspectj-users@xxxxxxxxxxx
>>>>>>> https://dev.eclipse.org/mailman/listinfo/aspectj-users
>>>>>>>
>>>>>> _______________________________________________
>>>>>> aspectj-users mailing list
>>>>>> aspectj-users@xxxxxxxxxxx
>>>>>> https://dev.eclipse.org/mailman/listinfo/aspectj-users
>>>>>>
>>>>>
>>>>
>>>
>>
>