[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [aspectj-dev] eclipse 3.1m6 has rudimentary API enforcement

Might it be possible to suggest to the Eclipse team that they could
make use of the AspectJ libraries, or would that not be a good idea?

Cheers,
Jim

On Apr 5, 2005 3:36 PM, Oli B. <boehm@xxxxxxxxxx> wrote:
> Hello,
> 
> one question to 3.1M6: does the actual AJDT build works with it? On the
> download page is mentioned "3.1M5a only"?
> 
> regards
> Oliver
> 
> Mik Kersten wrote:
> > Note that Eclipse 3.1m6 has added some rudimentary support for access
> > rules that let you do a similar thing to declare error/warning.  This
> > sort of IDE feature could work better with the pointcut language than
> > with the wildcard patterns they support.
> >
> >
> >
> > *Access rules on libraries and projects*
> >
> >
> >
> > Access rules can be defined on referenced libraries and projects so as
> > to explicitly allow/disallow/discourage access to specific types.
> >
> > picture of Build path wizard with access rules
> >
> >
> >
> > From:
> > http://download.eclipse.org/eclipse/downloads/drops/S-3.1M6-200504011645/eclipse-news-all-M6.html
> >
> >
> >
> >
> > Mik
> >
> >
> >
> > --
> >
> > http://kerstens.org/mik
> >
> >
> >
> >
> >
> >
> > ------------------------------------------------------------------------
> >
> > _______________________________________________
> > aspectj-dev mailing list
> > aspectj-dev@xxxxxxxxxxx
> > https://dev.eclipse.org/mailman/listinfo/aspectj-dev
> 
> --
> Oliver Böhm
> http://www.javatux.de
> 
> _______________________________________________
> aspectj-dev mailing list
> aspectj-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/aspectj-dev
>